Do not input private or sensitive data. View Qlik Privacy & Cookie Policy.
Skip to main content

Announcements
Congratulations to the new Qlik Luminary and Partner Ambassador class! Meet them here
cancel
Showing results for 
Search instead for 
Did you mean: 
jonip_78
Partner - Creator
Partner - Creator

Migrating Qlik Sense to New Server

Hi,

We need to migrate Qlik Sense Enterprise (May 2025) from Server 2012 R2 to Server 2025.

I found the support articles that have detailed instructions but couple of questions.

1. When I install Qlik Sense May 2025 to new server can I use the same licence temporarily on the new and old server before we shut down the old server?

2. When I do the backup of Qlik Sense on the old server I understood it does backup of everything (repository database, Qlik Share folder, QMC settings etc). Is that correct?

Labels (1)
11 Replies
Lauri
Specialist
Specialist

I would not attempt to restore a backup from Postgres v14.8 to v14.17. It has a good chance of failing. The versions of Postgres and Qlik need to be identical on the old and new servers. (Also, a year ago, it was necessary to uninstall any Qlik patches before taking the backup.)

While the instructions look complex, it's not bad, once you are familiar with pgAdmin. I have gone through upgrades and migrations that didn't succeed, so I learned to take it slow, have a complete list of steps to follow, and most critically, have the ability to restore the operating system (on the new server) from a snapshot after a failure. When a Qlik installation fails, it REALLY fails. Don't try to fix it, just restore the system.

Triple-check that you have your file paths right for the installation folders. It's easy to make a mistake like install to C:\Program Files\Qlik\Sense\Repository\PostgreSQL\14 instead of C:\Program Files\PostgreSQL\14.

Good luck!

jonip_78
Partner - Creator
Partner - Creator
Author

I did this last week, and everything went smoothly. Thank you to everyone for your help!

I did have some issues with NPrinting Qlik Sense connections after installing Qlik Sense on Windows Server 2025. The temporary workaround was to add the following entry to the NPrinting server's Windows hosts file and flush the DNS cache:

<QLIK_SENSE_IP> qliksense01.example.local

After that, the NPrinting connection verification passed.