Skip to main content
Announcements
Qlik Introduces a New Era of Visualization! READ ALL ABOUT IT
cancel
Showing results for 
Search instead for 
Did you mean: 
zagzebski
Creator
Creator

Creating a simple webpage with Word - iframe

I have virtually no experience with web pages so just trying to build a simple web page (saving a word document as a webpage - html).

Looking at other posts  - I came up with putting the following in a Word document and then saving as a webpage, then opening this page in a browser but all I get is the code below and it does not show the embedded QlikView object:

<body>

<iframe src='https://dhsqvdevsense1.dhs.ad.deanhealth.com/single?appid=4cb917a7-1f31-49c5-ae51-97064d56e6ad&sheet=JTqPRTb&opt=currsel&select=clearall' style='border:none;'></iframe>

</body>

Zag

1 Solution

Accepted Solutions
megabyte23
Contributor III
Contributor III

Good Morning. What you're trying to do is usually very simple, so we must be close.

Are you using Windows or Mac?

Can you copy the .htm file locally? For instance, if you're on windows, put it on c:\QlikSense.htm and try it from there? The "localhost" refers to your local machine set up as a web server. You shouldn't need anything like that just to open a .htm file in a web browser.

Also, do you have any other browsers installed? If you can try it in another browser, I imagine this problem is IE based.

View solution in original post

9 Replies
megabyte23
Contributor III
Contributor III

Do you have <HTML> tags surrounding it?

Like this:

<HTML>

<body>

<iframe src='https://dhsqvdevsense1.dhs.ad.deanhealth.com/single?appid=4cb917a7-1f31-49c5-ae51-97064d56e6ad&sheet=JTqPRTb&opt=currsel&select=clearall' style='border:none;'></iframe>

</body>

</HTML>

zagzebski
Creator
Creator
Author

Thanks for the reply Meg - still just seeing the code and not the Qlik Sense object.

Any thoughts?

megabyte23
Contributor III
Contributor III

When you open the page, it definitely has ".htm" or ".html" as the extension?

If so, are you showing file extensions? It could be "Page.html.txt", but you don't see the .txt. To see that, go to your control panel -> folder options -> view and uncheck "Hide extensions for unknown file types".

Then take off anything except the .htm or .html.

zagzebski
Creator
Creator
Author

Here is a print screen - still can't get it to work despite recommendations above. Anything look wrong:

megabyte23
Contributor III
Contributor III

Can you right+click the .htm file and open it in notepad? Look for any extra lines, especially lines that talk about "text" in the header. Make it so it's literally what we're seeing on your screenshot, save and try it again. MS Word has a tendency to throw a lot of extra code onto a page.

zagzebski
Creator
Creator
Author

Made some progress.  Now I just get a message that says "make sure you have the right web address: http://localhost:4848".  However I copied the iframe code right out of the dev hub single configurator.

megabyte23
Contributor III
Contributor III

Good Morning. What you're trying to do is usually very simple, so we must be close.

Are you using Windows or Mac?

Can you copy the .htm file locally? For instance, if you're on windows, put it on c:\QlikSense.htm and try it from there? The "localhost" refers to your local machine set up as a web server. You shouldn't need anything like that just to open a .htm file in a web browser.

Also, do you have any other browsers installed? If you can try it in another browser, I imagine this problem is IE based.

zagzebski
Creator
Creator
Author

Meg - thanks so much for sticking with me on this! Unfortunately I won't be able to get back at this till later today on my work computer.

zagzebski
Creator
Creator
Author

Meg - messed around a little today and got it to work. Could not have done it without all your suggestions. Thanks so much!

Zag