Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
gmenoutis
Partner - Creator II
Partner - Creator II

Active Directory users cannot login

I have installed QS on my company's server. I can successfully login to hub/devhub/qmc using the root admin created during the installation process.

Then, I set up a user directory connector to an active directory. This got me the needed users visible in qmc.

Then, I went to "Licences and tokens" and allocated a license to a specific user . It now shows Status "Allocated".

Then, I went to users and added RootAdmin to this user as role (afterwards, in my desperation, I also added ContentAdmin, DeploymentAdmin and SecurityAdmin).

Despite these steps, I am unable to use this new user to login to any of hub/devhub/qmc ( I get the username-password input box reappear, as though I input something wrong), while the original user works properly.

I am using a Windows 10 desktop PC as client, and the server is Windows Server 2012. I am using Chrome to login. As a username, I have tried gm (the userid seen in qmc), DOMAIN\gm, and gm@DOMAIN.

I have thoroughly searched around for solutions, and I have tried everything that was present in this post, to no avail. There is no file at all in %Programdata%/qlik/sense/proxy.


Could you please give me a hand?

1 Solution

Accepted Solutions
agigliotti
Partner - Master III
Partner - Master III

I think you should move the Qlik Sense Server from WorkGroup to Domain first as I said above.

View solution in original post

25 Replies
JustinDallas
Specialist III
Specialist III

What's happening when a user visits the site and tries to log in?

agigliotti
Partner - Master III
Partner - Master III

what's the user directory name the user belongs to ?

simon_minifie
Partner - Creator III
Partner - Creator III

Hi George,

Could you please upload the Proxy logs. They can be found in C:\ProgramData\Qlik\Sense\Log\Proxy

Regards,

Simon

gmenoutis
Partner - Creator II
Partner - Creator II
Author

I uploaded a zip here

http://www.filehosting.org/file/details/708802/Proxy.zip

Checking the files out, I only either see neutral things like "User authentication requested", or successful things like "Result=Success". So, for example, in the trace/servername_Audit_Proxy.txt file, lines 42781 and 42782 are Authentication request files. The first one was made when I tried to login with the gm user; nothing happens afterward. The latter was created when I logged in with the original user (qlik), and you can see there are some additional lines after which confirm the correct login, and which are missing from the previous case.

agigliotti
Partner - Master III
Partner - Master III

could you send a QMC screenshot where the user involved is listed under Users ?

rittermd
Master
Master

If your AD connection is setup correctly and working then the first time that a user hits your URL they will be prompted to login with their AD credentials.  If successful, then an account is created in QLIK.  If you have a security rule created then a token will be automatically allocated to them.

From that point on they can login and see whatever parts of the HUB they have access to based on security rules.

The fact that their user account shows up in the QMC would lead me to believe that they successfully logged in.

gmenoutis
Partner - Creator II
Partner - Creator II
Author

Here is both the Users screen and the access allocation screen.

qs_users.png

qs_accessallocation.png

awhitfield
Partner - Champion
Partner - Champion

Can you see the Synched/imported users under USERS in QMC?

Andy

gmenoutis
Partner - Creator II
Partner - Creator II
Author

Yes, I put an image reply to Andrea Gigliotti above.