Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

drudd75077
New Contributor II

Basic calculations don't seem to be working

I am trying to calculate the absolute value using FABS and Count on an amount column. However, my results didn't look accurate. I'm getting no value when I look for the absolute value by date. I'm getting some values when I look at absolute values by GL number and I get some information when I do a count by role.

However I know the absolute by date isn't accurate as it's showing me nothing, but the by G/L and by user id doesn't agree to SAP.

However, when I look at the count of rows by using (count of local) in my SQL database I'm getting the same number.

I'm really not sure why these what seem like basic math operators aren't returning what I was expecting. My underlying table is a straight table of my GL detail no joins or any extra scripting. Any ideas?

2018-07-26 19_40_10-Qlik Sense Desktop.png

ByDateAbsValue.pngbygl.pngcountagrees.png

1 Solution

Accepted Solutions
drudd75077
New Contributor II

Re: Basic calculations don't seem to be working

As I suspected, I'm an idiot. I need to wrap my absolute in a sum to get it to total the amounts. I think it was just converting my result to an absolute value (and my g/l detail nets to zero as it should)

1 Reply
drudd75077
New Contributor II

Re: Basic calculations don't seem to be working

As I suspected, I'm an idiot. I need to wrap my absolute in a sum to get it to total the amounts. I think it was just converting my result to an absolute value (and my g/l detail nets to zero as it should)

Community Browser