Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
linoyel
Specialist
Specialist

Can't connect to the hub from browser

Hi,

I'm trying to connect to qliksense from outside (from the browser) with external server address but it doesn't work - error message attached.

What is done already:

1. The external server address is added to the White Pages in QMC in Virtual Proxies

2. All server firewalls are down

3. All ports in the server are open

What else could it be? Something with proxies? Authentication?

Please help!

1 Solution

Accepted Solutions
linoyel
Specialist
Specialist
Author

OK, so as I thought, the problem was from System side.

They DID NOT open all relevant ports for Qliksense.

All these ports have to be opened in the server's firewall:

https://help.qlik.com/en-US/sense/1.0/Subsystems/Server_deployment_and_configuration/Content/Qlik%20...

The main QS ports are 443 and 4244 so first thing is to check they are opened in the firewall.

If they are opened and there is still no connection from the outside (from the browser), more ports have to be opened:

those two ports are used as long as you are using NTLM based Windows authentication. Depending on the usage of https or only http one of those ports needs to be open.

4244

Default Qlik Sense Proxy Service (QPS) authentication listen port. This port is used by the internal authentication module in the QPS when using NTLM in Microsoft Windows.

This port uses HTTPS for communication.

4248

Optional Qlik Sense Proxy Service (QPS) authentication listen port. The port is used by the internal authentication module in the QPS when using NTLM in Microsoft Windows.

This port uses HTTP for communication.

Thank you guys for your help!

View solution in original post

13 Replies
simon_minifie
Partner
Partner

Hi Linoy,

Have you linked the virtual proxy to a proxy?

From the Virtual proxy overview, check that 'Linked to proxy service' is a Yes.

best regards,

Simon

Chanty4u
MVP
MVP

Hi,

which browser you are using?   if google chrome do following.

goto settings--advanced setting --  uncheck the port

proxy settings do belowlan.PNG

or 

do please change the default browser to  IE . and refrresh the browser. aand let me know.

linoyel
Specialist
Specialist
Author

Hi Simon,

Do I have do do it in QMC or somewhere else?

Do you mean to do this?

https://help.qlik.com/en-US/sense/2.1/Subsystems/ManagementConsole/Content/link-virtual-proxy-to-pro...

If yes, I see it's linked by default.

simon_minifie
Partner
Partner

Hi Linoy,

In the QMC.

Open the virtual proxy, and then look at the bottom of the right hand properties menu under associated items: There is an option there of Proxies.

Click on that, and then link the virtual proxy to a proxy node.

The option is annoyingly greyed out, so it's easy to miss.

thanks,

Simon

linoyel
Specialist
Specialist
Author

Hi chanty,

Attached is the Internet Properties configuration as it is now.

What exactly do i have to change in it?

**It doesn't work in IE either

linoyel
Specialist
Specialist
Author

As I thought' it's already linked by default...

simon_minifie
Partner
Partner

Ok.. Could you check that all of the Sense services are running.

If they are, restarting the Repository Service will will restart all of the others.

I presume you can get to the hub from a browser on the server?

Thanks,

Simon

linoyel
Specialist
Specialist
Author

Yeah, all the services are running and I can get to the hub from a browser on the server.

I think there is something wrong from the System side.

The thing is that we had one server and then we bought a new one.

I've made QS server installation on the new server and transferred there QS projects.

From the system side, they're saying that they REDIRECTED THE SAME EXTERNAL ADDRESS from the old server to the new server, so now it's supposed to point to a new server's internal address and not to the old one.

I guess something went wrong in this redirecting. I'm not a system person, but maybe someone here can give me an insight so I can suggest to the System here what to do or what to check.


Chanty4u
MVP
MVP

Hi,

Can  you try to reinstall the server again and check .