Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Change number format to thousand

Hi

I have values for measure as 100000, 2000000, 300000 etc. I want values to be resprented as 100k, 200k, 300k.

I used expression like below but i am values like 100, 200 instead of 100k, 200k

If(SUM([Vbl.Val./COCrcy]) >= 1000000,

   Num(SUM([Vbl.Val./COCrcy])/1000000, '#.##0 M'),

   Num(SUM([Vbl.Val./COCrcy])/1000, '#.##0 K')

  )

Can you please let me know what i am missing

Thanks

6 Replies
ramoncova06
Valued Contributor III

Re: Change number format to thousand

is this in a table or a text object ?

if it inside a table go to numbers and change the symbol to "K"

for the one you were already working on remove the symbols from the num and use & to append them

the other option is

If(SUM([Vbl.Val./COCrcy]) >= 1000000,

   Num(SUM([Vbl.Val./COCrcy])/1000000, '#.##0')&'M',

   Num(SUM([Vbl.Val./COCrcy])/1000, '#.##0)&'K'

  )

Employee
Employee

Re: Change number format to thousand

try this (i am using "Sales" instead "[Vbl.Val./COCrcy]"):

If(Sum(Sales) >= 1000000,

   Num(Sum(Sales)/1000000, '#.##0M'),

   Num(Sum(Sales)/1000, '#.##0K')

  )

Not applicable

Re: Change number format to thousand

sorry about forgot to mention it is stacked bar chart. Not sure if it is still possible.

Employee
Employee

Re: Change number format to thousand

The number formatting for the Y-axis and the value labels on the stacked bar chart in Qlik Sense are auto-formatted.  And they will display K and M as needed.  Here's an example of both K's and M's showing automatically with Qlik Sense:

qlikSenseBarChartNumFormatting.jpg

vamsi6116
New Contributor III

Re: Change number format to thousand

Thanks for the reply.it does not show for me converting to automatically.My expression is SUM(fieldname)

Am i doing anything wrong

Thanks

Capture.PNG

Number.PNGYaxis.PNG

vamsi6116
New Contributor III

Re: Change number format to thousand

I am able to achieve this now. had to change it to custom and change format pattern.