Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Changing data source

Hi, I had made an app and then changed the data source to a newer CSV with the same data structure and same name but now all the master item references aren't working when I reloaded the data. There are a number of messes that I've created here. What is the best overall process when updating the old CSV data with new CSV data in Windows explorer and then reloading it in Qlik so that the new data just updates in my Qlik app?

1 Solution

Accepted Solutions

Re: Changing data source

Are you sure that the data-structure and the content of the file is really the same? To ensure this create a new app and drag the csv on it and use the wizard to have a preview on the data and after them compare the load-statement with your origin load-statement - I think you will discover some differences.

- Marcus

5 Replies

Re: Changing data source

Are you sure that the data-structure and the content of the file is really the same? To ensure this create a new app and drag the csv on it and use the wizard to have a preview on the data and after them compare the load-statement with your origin load-statement - I think you will discover some differences.

- Marcus

Not applicable

Re: Changing data source

Did you try to change your load script with the new filename or did you reload it again using a wizard? The reason I ask is for example with Excel there is an older format and a newer format and some end up with 'ooxml' in the script and others end up with 'biff'.  If you don't have the right one then nothing works properly.

Perhaps just reload using something like the table wizard to make sure the filename and format is correct - then you can copy and paste that part into the rest of your script if need be.

jyothish8807
Honored Contributor II

Re: Changing data source

Hi Chris,

As a work around try to load the new csv file separately and copy and replace the line after from in to old code. Try to do a reload again.

FROM

(   .................................);

Regards

KC

Best Regards,
KC

Re: Changing data source

Hi Chris, can you check the name given to the connection and the name used in script? Maybe it has changed, I think it can happen when recreating the connnection using Hub (not in desktop) in newer versions of QS if the application was done in older versions.

I'm not very sure of this but it's easy to check.

Not applicable

Re: Changing data source

Thanks everyone for your answers. I have been very busy at work with other commitments but I will try these suggestions out shortly and apply actions here. Thanks again.

Community Browser