Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QLIKWORLD LIVE! MAY 16 - 19TH, EARLY BIRD DISCOUNTS! REGISTER TODAY
cancel
Showing results for 
Search instead for 
Did you mean: 
SebastienPreau
Contributor III
Contributor III

Cluster : refresh OK but users don't see updated data

Hello, 

We are experiencing a rather strange behaviour on our main cluster lately. I'll share here our predicament, in hope that some people with similar issue may suggest hints to solve it.

Here is the configuration : 

=> Version is September 2018

=> The cluster is constituted of one primary server who is doing the update and 3 secondaries for display.

=> Our main application is viewed by 400-500 users a day, load balancing on 2 secondaries servers

Here is the problem : 

=> When the application is updated, sales from the previous day are added to the application and the current date variable is incremented accordingly.

=> When connecting to the application, many users see the current date as correctly updated but the KPI "Daily sales" that is basically a set analysis filtering sales using the current date variable returns 0, as if data had not been updated (only the variable).

=> Not all the users have the problems : some see the the KPI correctly, some don't.

Additional considerations:

 => The same application, loaded on a stand alone server, never has the pb (but the number of user is around 50 max)

=> The pb has started when the number of user has increased, the threshold being around 300-350

=> Reducing drastically the app cache time to 5 min has changed nothing

=> The server are not undersized. RAM and CPU usage remains 

=> On week end, the app is loaded on sunday morning (no reload on Monday) and yet most user experience the problem on Monday morning.

 

 

 

 

 

 

Labels (4)
0 Replies