Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
WE ARE LISTENING! New Navigation for Qlik Community, Sept. 26: TELL ME MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
jeffpeters
Contributor II
Contributor II

Connection to the Qlik Sense engine failed for unspecified reasons.

Qlik Sense 3.1 server issues this message on login to hub: "An error occurred Connection to the Qlik Sense engine failed for unspecified reasons. Refresh your browser or contact your system administrator."

Any assistance or ideas would be appreciated. I'm relatively new to Qlik; this is the first time we've tried to install 3.1.

34 Replies
paulodantas
Creator
Creator

We could solve the problem when we redirect to the central node. On proxy node, IOS gives the websocket error and can't connect.

rohitk1609
Master
Master

Qlik Sense is accessing fine on my few clients but for a specific client it is not working when I asked to switch it some another internet access it is working fine. So I am sure its something relate to security. My question is do Client who is outside of your network need to open these ports in his machine or network too to access Qlik Sense ?

lsjogren
Partner - Contributor III
Partner - Contributor III

Hi Rohitk,  I have the same problem. Works fine for 40 clients but not for 4 of them outside office. Did you solved the problem?

rohitk1609
Master
Master

So those 4 clients are out of your network. You need to confirm three things from your 4 clients network provider or IT person:

1. Engine and Proxy section ports must open at our and in bound at end users 

https://help.qlik.com/en-US/sense/November2018/Subsystems/PlanningQlikSenseDeployments/Content/Sense...

you can use telnet to test ports

2. Websockets are accessible

3.  if any proxy server is there ask them do above settings into it.

4. your QMC=virtusl proxy=> white host list has all necessary values, like host name, fully qualified host name, IP and DNS name.

Please let me know if you will face any issue after doing above steps

 

Thanks,

Rohit

Steveo250k
Contributor II
Contributor II

It worked for me when I white listed (see previous posts) the fully qualified server name.

We had <qlik server> in the white list, along with all the IP addresses etc.

But I had to add <qlik server>.<domain>.com.  

Applying this caused services to restart, booting off any working connections.  But within seconds I was able to log in to the hub from my desktop.