Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

alex_adams
New Contributor II

Creating an association corrupts the Data Profiling service!

Hey everybody. I've been trying to build a QlikSense application for a while now. What a great and fun tool!

However, I've run into a really strange problem that I can't figure out any way to solve. I have two tables with a common field between them, so naturally they need to be in an association. The problem is, when I load both tables into the Data Manager, it does not detect that there is a common field in the tables and does not automatically create the association.

Okay, no problem, I'll just create the association manually. However when I do this, Qlik shows me that there is 0 compatibility between the two fields (represented by the circle with the colored bar going around it - in this case, the bar is RED and it is barely going around the circle at all.) Then when I click "Associate", Qlik thinks for a while, and then completes its task, but the two tables still have no association between them visually. And to make the problem even worse - if I click "Load Data" after doing this, the Data Profiling service breaks completely!

Every time I go into the Data Manager after this, I'll start getting the error message "Data Profiling service connection failed. Refresh your browser." and this will happen every single time I load the app, with no obvious way of repairing it. So from my point of view the entire app is then corrupted as I've lost the ability to load any more data. Thank god for backups!

Does anybody have any idea what's going on? Has anybody run into anything like this before?

4 Replies
alex_adams
New Contributor II

Re: Creating an association corrupts the Data Profiling service!

Still struggling with this - we need to get the app built but we can't load any data. "The Data Profiling service is not available" and now we are getting the error message "No available Qlik Sense engine was found."

Has anybody struggled with anything like this before?

Is there a better place to ask questions like this? Hoping to find some answers soon as we need to get our application built....

Digvijay_Singh
Honored Contributor III

Re: Creating an association corrupts the Data Profiling service!

Can you share a small sample of your data. Is the field you are trying to associate is of timestamp type? they don't match normally between different tables. The problem you are facing is unusual so I feel something wrong with the field values causing this issue. More can be identified once you share the sample data/app

rkspareek1992
Contributor

Re: Creating an association corrupts the Data Profiling service!

I am facing issue in qliksense server as:

Capture1.PNG

Kindly suggest how to resolve ????

MVP
MVP

Re: Creating an association corrupts the Data Profiling service!

Its better to create a new post to ask a question. By all means include a link to this thread if you believe that it will help explain your issue.

Creating an association corrupts the Data Profiling service!