Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

cancel
Showing results for 
Search instead for 
Did you mean: 
claudialet
Contributor III
Contributor III

Date field not recognized by date picker extension ?

 Here is the  load script for the date field 

Timestamp(Timestamp#([ Date field ], 'MM/DD/YYYY hh:mm TT') ) AS [ Date field ]

This field does not automatically show up in the Date Picker extension.

I tried date ( floor( [Date field])) in the script  but that does not work also. 

In the Excel file all the values are formatted as :  11/21/2018 01:15 PM

How do I eliminate the  01:15 PM  and make the Date Picker pick up the field ?

 

Any ideas ?

4 Replies
lfetensini
Partner - Creator II
Partner - Creator II

Check your data format, must be the same at properties from extension:

calendar.png

Support your colleagues. Remember to "like" the answers that are helpful to you and flag as "solved" the one that helped you solve. Cheers.
claudialet
Contributor III
Contributor III
Author

 No  the date field is still not being recognized by the date picker

Alvaro_Palacios
Support
Support

Hi,

When loading date fields via Data Manager, these will be automatically recognised and tagged as date fields. If you explore the auto-generated load script you'll see the following expressions for each date field:

Date(Date#(DateFieldName, 'DD/MM/YYYY'), 'DD/MM/YYYY') as formattedDate

If  still date picker object doesn't display/recognise that field, then try this trick:

  1. Select one of the available fields from the drop down
  2. Enable 'Advanced Setup' (i.e. 'ON')
  3. Use the expression editor to enter the desired field manually.

I hope this helps.

JuanGerardo
Partner - Specialist
Partner - Specialist

Hi, I suggest to tag the field as a date. These fields are shown by date picker:

Tag Field DateField With '$date';

JG