Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
Not applicable

Date not sorting properly when displayed as WWW MM/DD/YYYY

Hi,

I am new to QlikSense and trying to sort my chart properly as I can't seem to get it to sort properly when I want to display my date as

WWW MM/DD/YYYY (e.g. Mon 06/25/2017 ).


I am able to sort properly through sorting by numeric when displaying only MM/DD/YYY (Dimension used is dayname(order_date).

However, when I try to use the following dimension, I am unable to sort it properly - [weekday(order_date) &' '&dayname(order_date)]

Is there anyway that allows me to display my chart using WWW MM/DD/YYYY while still able to sort accordingly?

Thanks!

Tags (2)
1 Solution

Accepted Solutions
mov
Esteemed Contributor III

Re: Date not sorting properly when displayed as WWW MM/DD/YYYY

It is simpler than that...  There is no need  to concatenate weekday and date, just use format 'WWW MM/DD/YYYY' - it is dual by its nature.

5 Replies

Re: Date not sorting properly when displayed as WWW MM/DD/YYYY

May be use Dual function here

Dual(WeekDay(order_date) &' ' & DayName(order_date), DayName(order_date))

mov
Esteemed Contributor III

Re: Date not sorting properly when displayed as WWW MM/DD/YYYY

It is simpler than that...  There is no need  to concatenate weekday and date, just use format 'WWW MM/DD/YYYY' - it is dual by its nature.

Not applicable

Re: Date not sorting properly when displayed as WWW MM/DD/YYYY

Hi Michael, how could I use the format from the start, am I able to use it in an expression when building a chart:

For example, do i use it like this: " dayname([order_date],WWW MM/DD/YYY) "

mov
Esteemed Contributor III

Re: Date not sorting properly when displayed as WWW MM/DD/YYYY

It is

date([order_date], 'WWW MM/DD/YYYY')

Not applicable

Re: Date not sorting properly when displayed as WWW MM/DD/YYYY

hi,

Thank you for the explanation. It worked!