Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

jukah_do
New Contributor II

Dates after year 2079 do not work

Hi all,

I have weird problem with my dates. When I use this script combined with autoCalendar I get the date fields derived as expected:

Data:

Load

Document,

Date(Start_Date,'MM.DD.YYYY') AS Start_Date,

Date(End_Date,'MM.DD.YYYY') AS End_Date

Inline

[

Document,Start_Date,End_Date

A,05.10.2015,31.12.2055

B,12.10.2016,31.12.2079

C,06.06.2017,31.12.2079

]

(Delimiter is ',');

A.PNG

However, if a date is in year 2080 or later, Qlik Sense does not generate the date field:

Data:

Load

Document,

Date(Start_Date,'MM.DD.YYYY') AS Start_Date,

Date(End_Date,'MM.DD.YYYY') AS End_Date

Inline

[

Document,Start_Date,End_Date

A,05.10.2015,31.12.2055

B,12.10.2016,31.12.2079

C,06.06.2017,31.12.2080

]

(Delimiter is ',');

B.PNG

Any idea what is going on here? Thanks!

1 Solution

Accepted Solutions
jur
New Contributor

Re: Dates after year 2079 do not work

Try adding tag field EndDate with '$Date'; to your script.

Its a workaround but I hope that it will solve your issue!

/J

12 Replies
mark6505
Valued Contributor III

Re: Dates after year 2079 do not work

Hi,

I have just load your second script in my Qlik Sense and it loads fine.

I would check what your date format is set to in your load script.

Mine is SET DateFormat='DD.MM.YYYY'; - to match the base data.

Also i am on the latest version of sense

Mark

jukah_do
New Contributor II

Re: Dates after year 2079 do not work

Hi!

Mine is SET DateFormat='DD.MM.YYYY';

I don't think this is the problem since it works with all years before 2079.

mark6505
Valued Contributor III

Re: Dates after year 2079 do not work

I am on the latest release of QlikSense.

I have copied your script and change the Date Format and it loads fine.

jukah_do
New Contributor II

Re: Dates after year 2079 do not work

I am also on the latest version. Could you please post your app?

MVP
MVP

Re: Dates after year 2079 do not work

The LOAD should work like this:

Date(Date#(Start_Date,'MM.DD.YYYY')) AS Start_Date, 

Date(Date#(End_Date,'MM.DD.YYYY')) AS End_Date

Highlighted
jukah_do
New Contributor II

Re: Dates after year 2079 do not work

Thanks for the suggestion, but it does not help :/

MVP
MVP

Re: Dates after year 2079 do not work

it's wrong formatted:

Date(Date#(Start_Date,'DD.MM.YYYY')) AS Start_Date, 

Date(Date#(End_Date,'DD.MM.YYYY')) AS End_Date

jukah_do
New Contributor II

Re: Dates after year 2079 do not work

Yes, I saw that and tried like this, not helping.

jukah_do
New Contributor II

Re: Dates after year 2079 do not work

I can confirm now that if the date is until 18.01.2080 everything works perfectly with my script.

If the date is 19.01.2080 and later, the problem appears.