Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Talk to Experts Tuesday, January 26th at 10AM EST: Qlik Sense. REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

ERROR: CEF rendering exception. GRPC rendering request failed, error: Value cannot be null. Parameter name: value. in Nprinting report

Did anyone face this error in Nprinting.

If so, what could be the root cause for this.

Please let me know how to avoid this.

19 Replies
Contributor II
Contributor II


I Have been facing the same problem. I've found the solution in the link https://qliksupport.force.com/articles/000043430, it is a problem about connection.


No its not a Bug , Plz  Restart the services and check it will not give object rendering error.


No its not a Bug , Plz  Restart all the Nprinting Service i.e Engine , Scheduler, repo etc .services and check it will not give object rendering error.


Thanks for this. We found the issue was solved by explicitly putting :443 on the QlikSense proxy https url


We have the same issue after upgrading to NPrinting Sept'18, our Sense is Nov'17.

I tried to add the port to the connection as shown in this article  but it will not 'stick'.

I can add the port and select save, but it is missing when I open the connection back up.


Our current workaround is to bypass our network loadbalancer and point the connection directly to a proxy. 

The article says it applies to all versions, but we did not have the problem before upgrading to Sept'18.


The issue has re-emerged. 😞


The issue has re-emerged 😞


We are using Qlik NPrinting September 2018 SR2 Version: and experience this same issue. My report was created last week with no issues, and this worked fine and all of the sudden stopped working today. 

I tried adding the port to the proxy url in the connection, but the changes were not reflected by the NPrinting portal. 

Restarting the NPrinting services resolved the issue. I'm guessing this will be the fix until a more stable solution is provided. 





for all of you getting this issue with Qlik NPrinting November 2018 or newer versions on standard (not third-party extension) objects I suggest to contact NPrinting support.

For NPrinting versions older than Qlik NPrinting November 2018 I suggest doing a simple test:

  1. Reproduce the issue;
  2. Open NPrinting Web Console interface as an NPrinting Administrator;
  3. Go to Admin->Engine Manager page;
  4. Disable all the Engines;
  5. After they became offline, re-enable them;
  6. Try to export any image from a Sense connection (for example doing a preview with NPrinting Designer).

If you are able to export images right after having disabled the NPrinting engine the issue is probably related to old sessions. If possible upgrade to NPrinting November 2018 or newer versions.

If you instead are still experiencing the issue right after having disabled and enabled again all the engines it is probably related to some other configuration issue and an upgrade could not be enough to solve the issue. In this case contact NPrinting support.

Best regards


HI All, 

We did find a solution/hack to this issue. 

The issue shows up when you have an image or map in the template/report.
The  reason for this is sessions. The session which grabs the image from the app stays open. So the next time you are trying to generate the report, you get issues. 

Write a task in task scheduler, which restarts the QlikNprintingEngine task everyday. 

NET STOP "QlikNprintingEngine"
NET START "QlikNprintingEngine"


This command will restart the service and you won't face any issues. 
The resolution was confirmed on: June 2018 , NP, QS and NP Designer. 

Thanks and regards,