Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Keto
Partner
Partner

EXECUTE statement don't work on QS

Hello,

I need your help since I have no way to get an "EXECUTE" command to work in my QlikSense enterprise script...

The error message tells me not to be in standard mode and I followed all the guidelines I could find without success, including this one:

https://help.qlik.com/en-US/sense/June2020/Subsystems/Hub/Content/Sense_Hub/Scripting/ScriptRegularS...

I unchecked the correct options :

Keto_1-1649856889906.png


and I even made the right manipulations in case for qliksense desktop with the Setting.ini file :


Keto_0-1649856815696.png

I restarted all Qliksense services and it still don't work.
I really don't know what else to do ...

Keto_2-1649857286801.png

I promise i try my best, motivation is the key !
Labels (1)
1 Solution

Accepted Solutions
Albert_Candelario

Hello @Keto,

I might ask the obvious, but did you disable the Standard mode on all the engines as well as edit the settings.ini of all the engines nodes to add the attribute OverrideScriptSecurity=1.

Also remember to edit such file when the Engine node is stopped and double check the file is saved properly and it has not been added any additional extension on the file like it could be .txt or similar.

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer

View solution in original post

8 Replies
Filippo_Nicolussi_P

Hello @Keto  

 

The script erro is mentioning the "Script mode" in the help you mention there is a Information section: 

"This statement is not supported in standard mode. See File system access restriction

that refers to  https://help.qlik.com/en-US/sense/June2020/Subsystems/Hub/Content/Sense_Hub/LoadData/file-system-acc... 

for the server disabling the standard mode is done in QMC : 

"For Qlik Sense, standard mode can be disabled in QMC using the Standard mode property." 

 

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Keto
Partner
Partner
Author

Thank-you for your prompt response.

I'm not sure I understand but that's what I did, the standard mode is disabled as you can see on the images of my post.

What manipulation should I do to solve this problem ?

I promise i try my best, motivation is the key !
Filippo_Nicolussi_P

Right ; 

Two further highlight : 

1) Execute "echo help"   needs probably to be executed inside a "C:\Windows\System32\cmd.exe" ( here some options https://docs.microsoft.com/en-us/windows-server/administration/windows-commands/cmd) .

2) Did you tried to restart the Qlik Sense Engine Service ? 

 

 

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Keto
Partner
Partner
Author

I made many tests, regardless of the parameters of "EXECUTE" even if I write letters at random the error does not change.

I indeed restarted all the services, including the qlik sense engine service

I promise i try my best, motivation is the key !
Filippo_Nicolussi_P

A last try with syntax as per image below : 

Execute c:\windows\system32\cmd.exe /c  "echo help" ; 

executed.png 

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!
Keto
Partner
Partner
Author

I don't get the same result 😞

Keto_0-1649861747431.png

 

I promise i try my best, motivation is the key !
Albert_Candelario

Hello @Keto,

I might ask the obvious, but did you disable the Standard mode on all the engines as well as edit the settings.ini of all the engines nodes to add the attribute OverrideScriptSecurity=1.

Also remember to edit such file when the Engine node is stopped and double check the file is saved properly and it has not been added any additional extension on the file like it could be .txt or similar.

Cheers,

Albert

Please, remember to mark the thread as solved once getting the correct answer
Keto
Partner
Partner
Author

Hello, the problem came from one of the 3 nodes to which the file had not been correctly configured, the backup not having taken effect!
Your remark allowed me to see this point, thank you for all your contributions to the subject of this post 🙂

I promise i try my best, motivation is the key !