Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

omarbensalem
Esteemed Contributor

Exception while trying to restore Qlik Sense Site with RSM

eI'm facing some troubles while trying to backup then restore a QlikSense site. Here is what I did : (I followed the help https://help.qlik.com/en-US/sense/3.1/Subsystems/PlanningQlikSenseDeployments/Content/Server/Server-...)

1) Backup: For the backup, I've chosen to work with RSM:

a) I created a new folder in which I copied the RepositorySnapshotManager

b) I also prepared a backup folder "BackupSense" c ) I opened the cmd , placed my self under the folder where I've put the RepositorySnapshotManager : cd "c:/RSM/" then I taped this : RepositorySnapshotManager.exe -backup -path="C:\Users\Administrateur\Desktop\BackupSense" -databasePassword="*****" (the backup is a success)

backup.PNG

2) I then uninstalled the QlikSense to try to restore it in the same server:

a) I've put the Qlik_Sense_setup.exe in a folder

b) I have my backup sense folder

c) I then tried to restore the site by typing this in the cmd after placing my self in the folder where the rsm.exe exists: RepositorySnapshotManager.exe -restore -path=C:\Users\Administrateur\Desktop\BackupSense -installer=C:\Users\Administrateur\Desktop\InstallSense -databasePassword="****"-u="WIN-Q887L4EMVDQ\administrateur" -p="********"

But when I do so, I have first of all a warning telling me that I haven't entered user credentials while I did : WIN-Q887L4EMVDQ\administrateur which the same user I used in the first installation

warning.PNG

I continue and then appear the exception:

Capture.PNG

9 Replies
omarbensalem
Esteemed Contributor

Re: Exception while trying to restore Qlik Sense Site with RSM

Even with the Exception, I reinstalled the QlikSense, with the same user and password I specified in the CMD, I didn't start the services . Then, I manually copied all the backups that exists in the backup sense folder (apps, certificate, app content database etc) I copied them under ProgramData/sense/ and can see that my backup up apps are there (5 apps in total) :

apps.PNG

But they don't appear in the QMC; in fact nothing do ! What should I do? where to copy the backuped files?


Capture.PNG


Thanks !

omarbensalem
Esteemed Contributor

Re: Exception while trying to restore Qlik Sense Site with RSM

mto

rupamjyotidas
Valued Contributor

Re: Exception while trying to restore Qlik Sense Site with RSM

You will get more advises if you change the post to 'New to Qliksense' instead of Qlikview.

Employee
Employee

Re: Exception while trying to restore Qlik Sense Site with RSM

Hi Omar - I moved this to the Qlik Sense Forum and will *bump* it to the top.

Qlik Community - is there anyone that can assist Omar with this? I am in the middle of upgrading my lab to 3.1 SR2 and preparing for a product release - so I don't have a server environment to test this yet.

omarbensalem
Esteemed Contributor

Re: Exception while trying to restore Qlik Sense Site with RSM

I found the cause of the first error/exception (my bad !), when I enter this (the restore process):

RepositorySnapshotManager.exe -restore -path=**** -installer=**** -databasePassword="BMCTEAM@@2016"-u="****" -p="****"

It tells me if Qlik_Install_Sense.exe is the name of the install file; it's not !

I fixed that, the installation process started, but after a while, it failed with an exception : (expected registry key not found)

Here is an image showing the message:

Capture.PNG

markginqo
New Contributor III

Re: Exception while trying to restore Qlik Sense Site with RSM

Did you find a resolution for this issue, Omar?  I was experiencing the same error on a VMWare test box and it ended up being related to the domain\username being incorrect.

I believe you may also run into some issues with the certificates if Qlik Sense was installed under the local system account, here's a discussion about workarounds:

Repository Snapshot Error

omarbensalem
Esteemed Contributor

Re: Exception while trying to restore Qlik Sense Site with RSM

Hi Mak,

No yet. I have a question though, Let's suppose that when I'm installing the Qlik Sense, I don't choose to install it with local system credentials BUT choose a user.

This user is the admin of the session, so per analogy is the local system user?

With that, is it considered that qlik sense was installed under the local system account or this problem won't occur?

markginqo
New Contributor III

Re: Exception while trying to restore Qlik Sense Site with RSM

Hi Omar,

From my experience it saves a lot of headaches if you do create a service account and choose that account during the install process.  I believe that even if you are logged in as the service account when performing the restore, you will still need to provide the credentials for the service account in the RSM call (using the -u= & -p= parameters).  "Local System" is a odd type of account that is not entirely like other accounts (such as being "not recognized by the security subsystem"):

https://msdn.microsoft.com/en-us/library/windows/desktop/ms684190(v=vs.85).aspxServices screenshot.png

Not applicable

Re: Exception while trying to restore Qlik Sense Site with RSM

Having the same issue, any advices?

error code=-2146232800 tryng to restore backup.

Cheers