Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Uploads getting stuck in the virus scanner. We are investigating.
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

FIELD NOT FOUND ERROR

Hi there,

I am getting,

FIELD NOT FOUND      ERROR

when I make reload from oracle.

If ı delete some FIELD from my sql table, and reload it (even ı do not use it in qliksense graphs) it gives error.

That is awkward. Do ı have to use the same data table forever, even I do not use all fields of it????

ex:

my first reload:

FIELD1 - FIELD2- FIELD3

my second reload:

FIELD1-  FIELD3

(I deleted one field that ı do not use)

ERROR :

FIELD NOT FOUND   'FIELD2'

But I do not use FIELD2 in my graphs. (Qlikview had no error like that)

It makes Impossible to work like that. Any helps appreciated.

Thanks.

9 Replies
Highlighted
Contributor
Contributor

Hi

Are you using Select * while loading data from SQL table or you are using list of all columns during reload.

If you are using list of all columns then you might want to remove FIELD 2 from column list in QLiksense as well.

Highlighted
Partner
Partner

Hi,

There is a reference somewhere in your load script to FIELD2 still. Ctrl+F and look for it.

Highlighted
Contributor III
Contributor III

there is no reference  I load table as ,

select * from ,,

so it loads what is available.

But the thing I do not understand is why does Qliksense record my old field names and look for thme in each reload???

Highlighted
Master III
Master III

did you search the missing field in your load script? all the tabs if you have

Highlighted
Creator
Creator

Hi Firat,

To be fully explicit: Does this error from your Qlik part of script or the SQL part?

E.g.

LOAD Field1, Field2, Field 3;

SQL Select Field1, Field2, Field 3 FROM schema.table;


If you take out the SQL part without adjusting the Qlik part, e.g.

LOAD Field1, Field2, Field 3;

SQL Select Field1, Field 3 FROM schema.table;

The error comes from the Qlik part of the script, not the SQL part.

Can you share the actual script for the table that causes an error (you can take away "schema.table" names if you feel uncomfortable sharing these)?

KR,

Cheenu

Highlighted
Contributor III
Contributor III

The question is easy,

I load some table from oracle.

And I reload it.

When I make reload, if some field is missing QLİKSENSE GİVES ERROR.

it is that simple infact.

But I do not use that fields in anywhere in qliksense. Why does it make ERROR for a field that is not used in file?

Highlighted
MVP & Luminary
MVP & Luminary

Posting your load-script might be helpful.

- Marcus

Highlighted
Contributor III
Contributor III

Yes, I just ask that.

How can I remove FIELD2 from column list in Qliksense?

It should have been done automatically by qliksense, qlikview was doing that.

Highlighted
Contributor
Contributor

Hi Ada,

I tried your scenario in my script in Qliksense.I am not facing any such problem. It would be good if you post your script.