Skip to main content
Announcements
Qlik Connect 2024! Seize endless possibilities! LEARN MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Foodie123
Contributor III
Contributor III

Field not found error

Hello experts,

I am trying to reload my script but I am getting an error saying the Total_Loss_Cost field is not found and I'm not sure why.

I have attached the script below

Foodie123_1-1694012977952.png

Foodie123_2-1694012997938.png

Any help is appreciated.

Thank you.

Labels (1)
1 Solution

Accepted Solutions
RafaelBarrios
Partner - Specialist
Partner - Specialist

Hi @Foodie123 

that means that your error is happening after the exit script.

you were probably doing something like 

load
...
Total_Lost_Cost 
...
...
RESIDENT Autobook;

and that field didnt exists on Autobook table.

and should be:

load
...
Total_Lost_Cost 
...
...
RESIDENT [Earnix Modeled LC by BrokerID_GW];

store [Earnix Modeled LC by BrokerID_GW] into ........;

 

hope this helps,

help users find answers! Don't forget to mark a solution that worked for you & to smash the like button! 

View solution in original post

12 Replies
daturpin
Partner - Creator II
Partner - Creator II

It looks like you haven't defined the fields for

Total_BIUM_Loss_Cost, etc, that go into the expression for the Total_Loss_Cost field?

anat
Master
Master

Can you give a try like

sum(col1) +sum(col2) as total_loss

RafaelBarrios
Partner - Specialist
Partner - Specialist

hi @Foodie123 

But is the error happening when this part of the script is executed or later?

I would believe that it is happening later when you try to make a resident to this table.

Can you get the reload log?

 

Best,

Foodie123
Contributor III
Contributor III
Author

Hello Rafael,

The error is happening when I execute the script.

What is the reload log and where do I find that?

RafaelBarrios
Partner - Specialist
Partner - Specialist

hi @Foodie123 

I mean knowing if the script fails when it is loading the section of the script you are pasting here or later.

It makes sense for it to be later because as far as I see, your script is not calling the field, but creating it, so it doesn't make sense for it to say "not found"

 

now, the logs
if you are using Qlik Sense Server

RafaelBarrios_0-1694026062807.png

https://community.qlik.com/t5/Official-Support-Articles/How-to-find-the-Script-Reload-logs-in-Qlik-S...

 

but in Qlik Sense Desktop

RafaelBarrios_1-1694026444615.png

 

 

help users find answers! Don't forget to mark a solution that worked for you & to smash the like button!

 

 

Foodie123
Contributor III
Contributor III
Author

Sorry for the misunderstanding. Yes, the script fails later.

Foodie123_1-1694029079003.png

 

It fails here

Foodie123_2-1694029096265.png

 

I'm still not sure where to find the reload log in the desktop version.

RafaelBarrios
Partner - Specialist
Partner - Specialist

ok, now i can see a bit more.

first, this is Qlikview and not Qlik Sense.

 

now,  you may have several tables called Autobook
in picture #1  you load a table and give the name Autobook:

in picture #2 you created the Total_Lost_Cost but you are not giving it any name to the table, so it  may be assigning the same name as the QVD.

in new picture you are trying to make a resident from Autobook loaded table and calling this new table  as Autobook:, this new table will have the name Autobook-1 or similar.

 

my suggestion,

add a "Exit script;" after  the script in picture number2 and then take a look to the data model, you will be able to see the name of the table that has the Total_Lost_Cost field

 

Hope this helps,

help users find answers! Don't forget to mark a solution that worked for you & to smash the like button!

 

 

Foodie123
Contributor III
Contributor III
Author

Thank you. I will try adding the exit script. Where can I find the data model?

RafaelBarrios
Partner - Specialist
Partner - Specialist

click on the icon highlighted in green

RafaelBarrios_1-1694035227447.png

 

Hope this helps,

help users find answers! Don't forget to mark a solution that worked for you & to smash the like button! 😁