Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

ksomosera10
Contributor

General Script Error on Specific Field Name

Hi,

I just want to ask for a help if you've experienced the "General Script Error" on Qlik Sense.

I was loading a QVD file and find out that one specific field name was causing the error.

I comment it out and the whole script load was successfully executed.

Can you please provide me at least an idea how I can work it out?

It's already 3-days since I've encountered this and still have't got a solution.

The google search has different scenario which is not applicable on mine.

I hope you'll help me on this.

Thanks in advance to you!

4 Replies
ChennaiahNallani
Contributor III

Re: General Script Error on Specific Field Name

can you copy your script

ksomosera10
Contributor

Re: General Script Error on Specific Field Name

Here it is...

I just load the QVD file

[Spend]:

LOAD

     Key

    ,Region

    ,Sheet1.Country

    ,Sheet1.Brand

    ,Campaign

    ,"Month"

    ,Month_No

    ,[Year]         <<<---------------- This field name is the problem

    ,Quarter

    ,Amount

FROM [lib://Spend](qvd);

karthikoffi27se
Contributor III

Re: General Script Error on Specific Field Name

Can you try below script and let me know if the problem still exists.

[Spend]:

LOAD

     Key

    ,Region

    ,Sheet1.Country

    ,Sheet1.Brand

    ,Campaign

    ,"Month"

    ,Month_No

    ,Year       <<<---------------- This field name is the problem

    ,Quarter

    ,Amount

FROM [lib://Spend](qvd);

Many Thanks

Karthik

ksomosera10
Contributor

Re: General Script Error on Specific Field Name

yes I already did that.

I even use

Year as year-New


and

even rename the year field before storing into QVD.

all of it still return with "General Script Error"