Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

HUB Access problem on external and Internal environment

Dear All,

We are not properly access the HUB and it prompts different messages when access the URL on external environment step wise i show problem.

1. The message i get which attached here when access in the server it self and also on the External environment.

URL that i use is

This url is normally open every time but after this the Qliksense App url can not be access properly

--> https://<Ourexternal IP>:10443/hub/my/work

2. After the HUB url i try to open the Qliksene App url

Which is below Url

--> https://<Ourexternal IP>:10443/sense/app/e9053cd5-3ec9-487a-af04-57a1c4a905d1

After this i get error

Connection Error.png

3. When i refresh it comes some time other wise this above message of point 2 comes (Also when we press the refresh button on the Browser it comes some time other wise same messages again.

4. Also i confirm i add the external IP in the white list on the Qliksense Server also.

Please do need full on this issue as how the customer see the app by pressing the refresh button.

Thanks

Bosc

8 Replies
Not applicable

Re: HUB Access problem on external and Internal environment

Hi Bosc

Can you please zip the C:\ProgramData\Qlik\Sense\Log and email it to me: elvir.arslanovic@qlik.com. That will be the easiest way for me to help you with your problem.

Not applicable

Re: HUB Access problem on external and Internal environment

Hi,

I sent Log to you on mail id please check and revert ASAP.

Thanks

Bosc

Not applicable

Re: HUB Access problem on external and Internal environment

Did you try to use the full DNS name ( https://<hostname>:10443/hub/my/workname) instead of using the IP address in the URL https://<Ourexternal IP>:10443/hub/my/work ?

Not applicable

Re: HUB Access problem on external and Internal environment

Can you screenshot or send the contents of the dev tools console?  That will help identify the issue.  Typically, this message will appear as a result of whitelist omission and/or a problem with the web socket handshake.  Are you running through a network load balancer?  You may need to check if the nlb supports web sockets.

jg

Not applicable

Re: HUB Access problem on external and Internal environment

Yes but i get error, and try like as you suggested.

DNS_PROBE_FINISHED_NXDOMAIN

1. Some time HUB try to open take so much time and only circles shown

2. And many times when press refresh button on the google chrome it is opened, but again it is not opened.

Note:- I am not running with proper SSL Certificate.

It is not resolve yet

Thanks

Bosc

Re: HUB Access problem on external and Internal environment

Hi Bosc,

You have to add your domain name in the white list for accessing and in the whitelist add IP and the domain name there.

Regards

Anand

Not applicable

Re: HUB Access problem on external and Internal environment

Hi Bosc

Apart from Anand suggestion, please check the firewall of the server machine. The firewall should be off to access HUB from local computer.

Thanks,

Manash

ellenblackwell
New Contributor III

Re: HUB Access problem on external and Internal environment

I am having the same problem/receiving the same error message on cloud.qlik.com. Once logged in, I see Demo apps and Personal apps, but no app will open; and, I am unable to import apps. Worked fine previously. ???

Community Browser