Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Having issues on loading data in Section Access

Hi Qlik,

I'm currently using Qlik Sense 3.0. So I'm having issues on my script in the section access. I'm trying to access/load data from the qlik sense repository database.  No issues with it. But once  I load the data from a previously loaded table it locks my account. Here's my code:

LIB CONNECT TO 'ABC';
Users:
NoConcatenate
LOAD 'USER' as ACCESS, UserDirectory & '\' & UserId as USERID, NUM(Name) as NUMBER;
Select "C"."Name", "A"."UserId", "A"."UserDirectory"
From "TableA" "A"
inner join "TableB" "B" on "A"."ID" = "B"."BUser_ID"
inner join "TableC" "C" on "B"."B_ID" = "C"."ID";

SECTION Access;
NoConcatenate
LOAD upper(ACCESS), USERID, num(NUMBER)
Resident 'Users'; 

Section Application;

-----------------------------------------------------
But if I store the data from the joined tables into a file and then on the section access I load the data where I store it from(text file), it works perfectly not sure why the code above locks my user account. I even tried converting the "NUMBER" column.


Cheers,
sv

5 Replies
vinieme12
Esteemed Contributor II

Re: Having issues on loading data in Section Access

have you tried with preceding load?


LIB CONNECT TO 'ABC';


SECTION Access;

LOAD ACCESS,USERID,NUMBER ;

LOAD

USER' as ACCESS,

UserDirectory & '\' & UserId as USERID,

NUM(Name) as NUMBER;
Select "C"."Name", "A"."UserId", "A"."UserDirectory"
From "TableA" "A"
inner join "TableB" "B" on "A"."ID" = "B"."BUser_ID"
inner join "TableC" "C" on "B"."B_ID" = "C"."ID";

Section Application;

Not applicable

Re: Having issues on loading data in Section Access

Hi Vineeth,

Thanks for the quick response. I've tried with the preceding load, but no luck. It still locks my user account.

sv

Employee
Employee

Re: Having issues on loading data in Section Access

So to be clear, if you dump the same outputs as a QVD file then use that QVD file for Section Access then it loads successfully?

Not applicable

Re: Having issues on loading data in Section Access

yes it does...

rupamjyotidas
Valued Contributor

Re: Having issues on loading data in Section Access

Resident Load and Section Access sometimes doesn't work as intended, I don't have any explanation for that

Doing a resident load of mixed case data there may lock you out.

Just doing this would probably resolve your problem:

SectionTable:

LOAD Upper(ACCESS) as ACCESS, 

          Upper(USERID) AS USERID,

          num(NUMBER) as NUMBER

Resident Users;