Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
Qlik Insider: SaaS capabilities for Data Integration and Analytics, May 25th! Register Now
cancel
Showing results for 
Search instead for 
Did you mean: 
Coloful_Black
Contributor III
Contributor III

How to make a city level drill down at Mapping function Or I need to add Geo extensions ?

Hello masters,

Want to see if I could replicate a State to City level drill down with my current Qlik mapping fictions.

something like this ( This is a country to city)

The demo link  https://sense-demo.qlik.com/sso/sense/app/eed1c69b-3675-41f8-a852-4f71de096e50/sheet/pRbH/state/anal...

Quick snapshot 

 
 
 
 
 
 
 

Screenshot_1.png

 
 

My Qlik account has a Map chart with these 6 layers...My data contains zip code, city name and county. If I need to have an additional extension to build that State to City drill down? 

 

Screenshot_2.png

Thanks

 

2 Solutions

Accepted Solutions
Lisa_P
Employee
Employee

If you create a Drill down dimension master item with State>City.

Then create an area layer for State and a point layer for City, as you make selections in your drill down dimension the map will focus on what you select. Also in the Options for each layer you can also modify the Show in zoom levels under Layer display to restrict what you see based on the zoom level.

View solution in original post

Steven_Haught
Creator III
Creator III

Agree with Lisa here, City is not a great method to drill into as the geometry may not be in there to drill into.

I was able to create a drill down from State>Zip>IDN. I did this with two layers. First being an area layer with the drill as dimension, left auto on location, and placed 'US' in the Country. Then created a point layer with drill down as dimension and used a lat and long field created from your GeoPoint field as I had issues with geopoint mapping. This was created as follows:  SubField(Geopoint,',',1)as Lat, SubField(Geopoint,',',2)as Long. 

In layer display on the point layer I turned off visible in the upper layers:

Steven_Haught_0-1597153097356.png

I then colored the area layers by sum of Dollar units in order to "heat map" the locations. 

Hope this helps to point in the right direction, I know you were hoping to get cities but just don't think its the move here.

 

View solution in original post

10 Replies
Lisa_P
Employee
Employee

If you create a Drill down dimension master item with State>City.

Then create an area layer for State and a point layer for City, as you make selections in your drill down dimension the map will focus on what you select. Also in the Options for each layer you can also modify the Show in zoom levels under Layer display to restrict what you see based on the zoom level.

Coloful_Black
Contributor III
Contributor III
Author

Hi Lisa,

I am now stuck with the very first step of making an area layer for USA.

see the second screen shot of error message. Is that because of incorrect template of my State field?

What is APCL?

zacYS2020_1-1597081108856.png

 

 

zacYS2020_0-1597080934805.png

And only I change the location type into Admin area (level 1), it goes to USA.

Why not 'Country' does not work?

Please advise

Steven_Haught
Creator III
Creator III

This is due to using the state abbreviations. 

Administrative area (Level 1): First-level administrative area names. such as a state or province names.

https://help.qlik.com/en-US/sense/June2020/Subsystems/Hub/Content/Sense_Hub/Visualizations/Map/map-p...

Change the Location type to Admin level 1. 

Sharing a bit of your data would also be helpful here so we can help show you the drill down. 

Coloful_Black
Contributor III
Contributor III
Author

Hi Steven,

I attached my file here. It has state, city and even Geopoint I just mapped.

would you please take a look to see why I just can't get the drill-down (State to City) ?

 

Lisa_P
Employee
Employee

This should be your settings for State:

Lisa_P_0-1597102181203.png

Not all your cities were detected, so ZIP might be a better option to show each location.

Create a drill down dimension State, IDN and when you represent IDN as a point layer, use ZIP as location, Location type as Postal code/ZIP code and Country 'US' as above.

 

Steven_Haught
Creator III
Creator III

Agree with Lisa here, City is not a great method to drill into as the geometry may not be in there to drill into.

I was able to create a drill down from State>Zip>IDN. I did this with two layers. First being an area layer with the drill as dimension, left auto on location, and placed 'US' in the Country. Then created a point layer with drill down as dimension and used a lat and long field created from your GeoPoint field as I had issues with geopoint mapping. This was created as follows:  SubField(Geopoint,',',1)as Lat, SubField(Geopoint,',',2)as Long. 

In layer display on the point layer I turned off visible in the upper layers:

Steven_Haught_0-1597153097356.png

I then colored the area layers by sum of Dollar units in order to "heat map" the locations. 

Hope this helps to point in the right direction, I know you were hoping to get cities but just don't think its the move here.

 

Coloful_Black
Contributor III
Contributor III
Author

Hi Steven,

Thanks again for your advise. yeah... It works ....

Just another followup question.  is that way to show the full number? here only shows 2..... , it actually is 2.8K or 2800.

It is a simple area layer with State as location. I customized  the color by expression of =aggr(SUM([Pack Units]),[State])

The area layer only show portion of number not all of them...anyway to adjust into full number display?

 

HardToGiveAname2020_0-1597292275209.png

 

Steven_Haught
Creator III
Creator III

Great to hear! For the label you can try the following: In the area layer, go down to tooltip. Turn on Custom and put your formula in the measure. Turn off auto format and show as number. 

Coloful_Black
Contributor III
Contributor III
Author

Hi Steven,

Maybe I missed somewhere....do not find a format option at color section under area layer ....there is a one of label at General setting where I tried to put my formula ....but still does not work...

 

would you mind showing me a screen shot or something? 

 

 

 

HardToGiveAname2020_0-1597325286985.png

HardToGiveAname2020_1-1597325691420.png