Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

i_bagnoli
Contributor

Hub not opening - G3 Broker API

Hi community,

in server, where Qlik Sense is installed, we stopped internet connection. Till that moment QS worked fine, but now, after reboot something went wrong.

I know Qlik Sense can work without internet connection, but now I receive this kind of error when connecting to the HUB (while I can correctly open QMC):

Cannot establish connection: Qlik Sense G3 Broker API.

What's that? I can't find anything on web... can you help me please?

Thanks a lot

IB

Tags (3)
1 Solution

Accepted Solutions
i_bagnoli
Contributor

Re: Hub not opening - G3 Broker API

It's been resolved: the problem was that another executable was using port 9028 instead of qlik.

It's always important to take a look at the logs.

11 Replies
rittermd
Honored Contributor

Re: Hub not opening - G3 Broker API

Getting to the QMC is different than getting to the Hub.  The QMC can work fine while the Hub doesn't.

When you say that you stopped the Internet connection what does that mean that you did exactly?

When the server rebooted do you have internet connection?

Are all of the QS services running?

i_bagnoli
Contributor

Re: Hub not opening - G3 Broker API

Hi Mark,

thanks for your reply.

Exactly I don't know what has been done to the machine, maybe some installation too in order to improve security (it has been at customer's discretion). Certainly there is no internet connection at the moment (only local net) but all services run well.

I investigated a little more and I found an error in Hub Service Log: "Fatal error when starting the HubService ,Error: listen EADDRINUSE :::9028". So I think it's a problem on port 9028, which is listening, but (maybe) in use by another application. I exposed the situation to the customer and I'm waiting for a reply... there's something else I could take into account?

rittermd
Honored Contributor

Re: Hub not opening - G3 Broker API

I would confirm that all QS ports are still open and not being used by something else or blocked by firewall.

i_bagnoli
Contributor

Re: Hub not opening - G3 Broker API

It's been resolved: the problem was that another executable was using port 9028 instead of qlik.

It's always important to take a look at the logs.

idogridish2
Contributor II

Re: Hub not opening - G3 Broker API

Hi i.bagnoli,

how can i check if eny other service is listening to port 9028 ?


i have the same issue:

Capture.PNG

i_bagnoli
Contributor

Re: Hub not opening - G3 Broker API

Hi idogridish,

I used netstat -a -b in cmd.

Port 9028 should be used by node.exe (qlik) instead of any other exe.

eightieschild
New Contributor III

Re: Hub not opening - G3 Broker API

Hi Irene

We're seeing this same issue following an upgrade to v3.2.5 this morning.

How did you resolve it?

Thanks

Chris

shraddha_g
Honored Contributor III

Re: Hub not opening - G3 Broker API

check logs

eightieschild
New Contributor III

Re: Hub not opening - G3 Broker API

Thanks for the response Shradda, but this is not what I asked.

I would like to know how Irene resolved this issue?

Thanks

Chris

Community Browser