Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor III
Contributor III

Inline Table Filtering Issue

Hello All,

I have a simple inline Table

Cost_Rev:
LOAD * Inline [
Name
'Supply East'
'Revenue West'
'Supply North'
'Revenue West'
 ];

I have two selectors pane:

First Selector pane will display all the values,

Field: "Name": will display all the values

in the second filter if I have to display only "Revenue" fields, so I wrote the below condition to display.

Field:  =aggr(Only({<Name={"*Revenue*"}>}Name),Name)

Which will display only Revenue, works fine.

The problem is that the second filter not automatically getting selected when you select from the first filter

i.e When I make the selection in the first filter, the second filter is not turning in to green selection, rather it's having a white selection (filtering properly).

For the testing, I have changed the condition to the field name "Name", which works with the "Green Selection"

Can anyone please help to resolve this issue

 

 

 

 

 

 

 

 

 

 

 

Labels (3)
3 Replies
Partner
Partner

This is how Qlik Sense associative engine works, green is only for dimensions that you actively selected and white are possible values in other dimensions based on you green selections.

The only way to get around this, as I see it, would be to build an extension that is working with the engine API doing the selecting for you automatically.


Read more on the associative selection model here: https://help.qlik.com/en-US/sense/April2019/Subsystems/Hub/Content/Sense_Hub/Selections/associative-...
Plees ekskuse my Swenglish and or Norweglish spelling misstakes
Highlighted
Contributor III
Contributor III

Make sure to use Filter pane from chart, and not drag and drop. (worked for me)

Highlighted
Contributor III
Contributor III

Make sure to use Filter pane from chart and then assign dimension, and not drag and drop the dimension from 'Fields' which will create an automated pane.

works for me:)