Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

rittermd
Honored Contributor

Internal Server Error when Searching

When user tried to do a Universal Search they would get an Internal Server Error box.   You could close the error box and proceed.  It did not kill the app.  But you could not do a search of any kind.

Because this app was one of the few that we have that uses a TreeMap I started focusing on that.

I remove the entire TreeMap and the error went away.

Then I put it back and the error was there.

So I dug into the Tree Map.  It contained 3 Dimensions and 1 Measure. 

I tried several things but it seems that by removing the = in front of the expression and leaving the rest as is,  that my error went away. 

Capture.PNG

I don't know why the = is there and I don't know why removing it made a difference. 

Has anyone else seen this or can explain why this made a difference?  I am glad that it is working.  But would like to understand.

Thanks

Community Browser