Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Highlighted
klrameet
New Contributor II

Issue with the default filters and their graphs

Hi Guys

Situation: I have to keep the first two plots, regardless of the selection users make, from the rest of the bars. eg when user select the third graph for drilldown/selection, graph should display 1+2 & the 3rd one or any other that he has selected, keeping 1 & 2 on always.

Using expression, I could manage to keep the 1& 2 bars there always, but when the selection is made, the first two graphs are getting grayed out for some reason.

I can see that somehow the dimension determining color, is not getting assigned properly as highlighted in screen 2 & 3, whereas i can see it getting populated in header of tool tip.

The expression, i am using on reported total is:

if(getselectedcount([Name])=0,Sum([Amount]),Sum({$<[Name]+={L2,L3}>}[Amount]))

where L2 & L3 are name for the first two bars.

Capture3.png

agigliotti zhandos_shotan vegar.lie.arntsen stalwar1 .

6 Replies

Re: Issue with the default filters and their graphs

Legend always consider as Legend only. So, For that you need to define as Dimension. Could you please look the dimension or share with us application which holds Mock data

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
klrameet
New Contributor II

Re: Issue with the default filters and their graphs

loveisfail

Both Name & Account type are set up as dimension only.

I have expression for the measure as:

if(getselectedcount([NAME])=0,Sum([REPORTING_AMOUNT]),Sum({$<[NAME]+={'L2','L3'},[SCHEDULE]+={'L2','L3'}>}[REPORTING_AMOUNT]))

Capture5.png

vegar.lie.arntsenstalwar1agigliotti

I think issue is with value assignment. Coz when initially graph is plotted, I can see L2 & L3 getting their Account types values populated correctly, as shown in initial image, whereas when I make selection, somehow the values for account types are getting screwed up .. not sure why ..

Re: Issue with the default filters and their graphs

There is no wrong in your expression, Can you bifurcate your expression into 2 parts and check. Or else I would like to ask Application to test?

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
klrameet
New Contributor II

Re: Issue with the default filters and their graphs

‌ccan you plz advise on how to split the expression ?

Luminary
Luminary

Re: Issue with the default filters and their graphs

I think I've seen this when I tried to use library colors (color by dimension). If I remember correctly I had to switch to auto colors. It was not exactly what I wanted, but still better then grey bars. Try to play with color settings and see if you get a better result.

klrameet
New Contributor II

Re: Issue with the default filters and their graphs

juraj.misina Unfortunately, It didn't work for me. I tried using auto colors but still getting the issue. I am have gut feeling that it's coz of the expression.