Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Issues with the geomakepoint-function --> Latitude&Longitude

Dear all,

I´m trying to create a map on QlikSense Desktop with an uploaded Excel-file, but unfortunately it doesn´t work out..:/ I´ve checked the respective tutorial as well as relevant posts, but I still couldn´t solve the issue..

In fact, according to the tutorial two solutions are suggested, either via creating a new dimension where the "geomakepoint"-function is typed in or via the "Data Load Editor". However, solution #2 is more recommended for future versions. The strange thing is that when I go to the "Data Load Editor"(after I´ve uploaded my Excel-file with respective coordinates), the file is not named (like in the tutorial), but it says "Auto-generated-section". Even though, after I have unlocked the file, I can add the "geomakepoint"-function and merge the Long and Lat, nothing happens. What would be the next steps actually, after I´ve added the function here in the "Data Load Editor", how should I proceed? It is fine just to save and leave the "Data Load Editor"? I did so, but nothing happened. On the other hand, when I go for solution #1, and type in the function as recommended by the tutorial, it doesn´t work. I could only add the separate columns to the map. I also tried the other functions suggested in the forum, but this also didn´t work...:/

I would be very happy if someone could help me out!




2 Replies
Honored Contributor II

Re: Issues with the geomakepoint-function --> Latitude&Longitude

Hi Michael,

Sounds like you have done every thing right, but is it possible to share the code so that it would be easier to figure out where the issue is?


Sangram Reddy.

Not applicable

Re: Issues with the geomakepoint-function --> Latitude&Longitude

HI Sangram,

thanks a lot for your fast response!

Please find attached two screenshots -->

#1 - That´s how my Data Load Editor looks like when I enter (after uploading the Excel File to Qlik Sense)

#1.jpgI´m already a bit confused that on the left side instead of the file name where the data come from, it just says "Auto-generated Section (in contrast to the tutorial, where on the left it says the name of the file and on the right side (below "Data Connection") the folder is mentioned where the data come from - in my case nothing is mentioned on the right side.

Furthermore, I have to unlock the file first before I can edit. However, the column names indicated are all according to my Excel file, so that should be right on the other hand...

Nevertheless, I have this feeling that here might be something wrong already...

#2 - In the next step I tried to adapt the Lat and Long according to the tutorial -->


Anyway, what is actually the right procedure after having done so. Just "save" the Editor and after that leave the Editor and go back to the Sheet? Should than be the "Dimension" for Lat&Long already in the sheet? Anyway, I my case nothing happens....

I also tried various Geomakepoint-functions, as suggested in some tutorials (with inserting of "#" and so on), but the results are not promising yet...:/

I would be very happy for a good advice!

Thank you!