Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

KPI Conditional Colors functionality is broken

Has anyone else come across this issue?

When I add a conditional color to the KPI it works the first time around, however if I turnoff the conditional color button and turn it back on the color bar disappears along with the expression editor.

I have tried closing Qlik Sense and reopening and closing the app and reopening it but that does not seem to work. Even when I create a new KPI I have the same issue. I'm not sure if this is a bug it is my first time using the functionality.

Any help is gladly appreciated.

Henry

9 Replies
rittermd
Honored Contributor

Re: KPI Conditional Colors functionality is broken

Desktop or Enterprise?

What version?

Not applicable

Re: KPI Conditional Colors functionality is broken

Desktop 10.28.2

rittermd
Honored Contributor

Re: KPI Conditional Colors functionality is broken

You are not on the latest version.  Would it make sense to upgrade and try it again.

The latest version is 11.11.2

Not applicable

Re: KPI Conditional Colors functionality is broken

Hi Mark,

I updated to the latest version 11.11.2 but the issue persists.

conditional_color_error.JPG

Henry

Highlighted
rittermd
Honored Contributor

Re: KPI Conditional Colors functionality is broken

I can't replicate this.  Works fine on my system.  Have you tried a different browser?  I am using Chrome.

Not applicable

Re: KPI Conditional Colors functionality is broken

I have used IE and Chrome.

What would you suggest for next steps?

rittermd
Honored Contributor

Re: KPI Conditional Colors functionality is broken

Can you try different measures just to see if something in the expression is causing this?  Make them very simple.  Like count(field).

What measures do you currently have there?

Not applicable

Re: KPI Conditional Colors functionality is broken

I am using this Avg({$< [Status Code]={'ATP'}>}duration)

I tried a simple expression such as count(orders) with a new KPI, selected then unselected conditional buttons and there was no issue.

yufaichristophe
New Contributor

Re: KPI Conditional Colors functionality is broken

kurleigh.henry

I have the exact same problem here.

I have found a manual (albeit tedious) solution, however.

So if this problem comes up, you click on 'Add Limit' once.

  1. Then, you turn off 'Conditional Colors'.
  2. Then you turn on 'Conditional Colors' again. The continuum comes up again, and just click 'Remove' on the extra conditional line you just created.
  3. Click 'edit expression' to resume working on your conditional coloring.

This isn't a complete fix, but is a solution that works in the meantime while the tech people at Qlik resolves this bug.

Community Browser