Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
See why BI users voted Qlik #1 in 11 categories. GET REPORT
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Load balancing blocks data connections list

Hello,

This is the original question :

recently we updated our load balancing rules to allow only certain streams on a certain rim node.

Everything worked as expected until we needed to modify our data connections in one of our applications data load editor.

There are a few post about the "Spinning data connections" (like this ) but the question goes unanswered and does not seem to relate to this next happening.

The data connections list does indeed keep spinning in our application and the browser console outputs the following error:

api/dataprepservice/v1/apps//model/current:1

Failed to load resource: the server responded with a status of 500 (Internal Server Error)

What this error is, we have no idea. But what we did find out is what causes it.

Accessing data load editor through an app on our central node, that is load balanced to only show on central node, blocks the data connections list from rendering successfully.

When accessing an app that is also accessible on our rim node, the data connections list renders without problem.

I was able to recreate this problem multiple times by allowing all applications on both nodes and voilá, the data connections render.

Now this causes a problem, because we want to filter certain apps from being loaded on our rim node, but the only way to render the connections list requires the app to be available on both.

What we also did try was to use different resource filters (DataConnection*. App.DataSegment* etc.) in our load balancing rules but the only one that had the desired effect was to allow resource App* or App_* on rim node.

Has anyone encountered this problem before or have any idea how to fix/go around it?

All the data connections are accessible on our QMC, tasks and such, even though they do not render as a list in data load editor, so this must not be an ODBC or some like problem.

Also, we are using Qlik Sense Server with June 2018 version.

We did also try booting up the server.

Your help and wisdom is much appreciated,

 

I have the same error and I open a case on Qlik support portal : 01673210 - LOAD BALANCING BLOCKS DATA CONNECTIONS LIST

We found a solution, but the problem reappears. I attached to the ticket a backup of my environment.

I open a new case in the support portal site but maybe you have an idea ?

Thanks,

Paul

 

1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Hello,

The June 2019 version fixes the problem.

Regards,

View solution in original post

3 Replies
Highlighted
Contributor
Contributor

Hi Paul,

 

Can you please let us know if you have got any FIX for this.

 

Thanks,

Rangam

Highlighted
Partner
Partner

Hello,

The June 2019 version fixes the problem.

Regards,

View solution in original post

Highlighted
Contributor II
Contributor II

I presented this issue to the Infra Team and they enabled access on the HUB to the internet.
Central node already had access and had no issue when load balancing pointed to the central node server.