Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

morenoju
Contributor III

Loading data from a Postgres DB

Hi all,

I have an Qlik Sense app where I load data from a Vertica DB. Now, I need a couple of tables from another database, a Postgres DB. So I've done the following:

- I've created an ODBC source in my Qlik Sense server, with the Qlik-postgres driver. I've tested it, and it says it connects.

- I've added the connection to that source to my script.

- I've clicked on "Select data to load".

At that point Qlik Sense shows the loading circle indefinitely, without letting me choose Database and Tables.

Any idea on what may be happening?

Thanks,

Juan

1 Solution

Accepted Solutions
morenoju
Contributor III

Re: Loading data from a Postgres DB

All this was being very confusing because in the "ODBC Data Sources Administrator" in Windows I could test the connection and it would work.

The reason why it didn't work in Qlik Sense is that I was inserting the user/password once again when creating the ODBC data connection in Qlik. It has to be left blank. The user/password is already there in the ODBC Data Source configuration.

Note: I checked the version of my PostgreSQL database doing "SELECT version();" in pgAdmin and I made sure I installed the same version of the driver. I had to choose between PostgreSQL30 (ANSI) and PostgreSQL35W (Unicode). I read Unicode is more common, so that's the one I'm using.

9 Replies

Re: Loading data from a Postgres DB

Hi,

Not sure what would have caused that, but if you know the table name you can simply write that in script like below.

Sql Select * from xyz;

Regards,

Kaushik Solanki

morenoju
Contributor III

Re: Loading data from a Postgres DB

I already tried that, but it hangs right after the connection.

morenoju
Contributor III

Re: Loading data from a Postgres DB

I still can't find the reason for this not to work.

Do you think that maybe the version of PostgreSQL can be a problem?

My DB version is: PostgreSQL 9.1.10 on x86_64-unknown-linux-gnu, compiled by gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-54), 64-bit

balabhaskarqlik
Honored Contributor

Re: Loading data from a Postgres DB

Did you able to resolve this issue, post the solution.

morenoju
Contributor III

Re: Loading data from a Postgres DB

Unfortunately not, Bala. I gave up, although including data from PostrgeSQL would have been very good for the dashboards I was working on at that time.

Re: Loading data from a Postgres DB

Can you check if that helps How to pull data from PostgreSQL to Qlik

Life is so rich, and we need to respect to the life !!!
morenoju
Contributor III

Re: Loading data from a Postgres DB

Hi Anil,

Thanks for the link. I see it refers to Qlikview though, does it apply to Qlik Sense too?

I've been trying to connect to Postgres again today and it does not show any error, but the drop down lists for Database and Owner are disabled.

Thanks,

Juan

Screenshot_1.png

Re: Loading data from a Postgres DB

You are pulling data directly, Have you given correct Connection?

Life is so rich, and we need to respect to the life !!!
morenoju
Contributor III

Re: Loading data from a Postgres DB

All this was being very confusing because in the "ODBC Data Sources Administrator" in Windows I could test the connection and it would work.

The reason why it didn't work in Qlik Sense is that I was inserting the user/password once again when creating the ODBC data connection in Qlik. It has to be left blank. The user/password is already there in the ODBC Data Source configuration.

Note: I checked the version of my PostgreSQL database doing "SELECT version();" in pgAdmin and I made sure I installed the same version of the driver. I had to choose between PostgreSQL30 (ANSI) and PostgreSQL35W (Unicode). I read Unicode is more common, so that's the one I'm using.

Community Browser