Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

macdonaldm
New Contributor

Loading empty rows

Hello, When I load my data one of my tables is loading 999 rows, 989 of which are empty. Do you know how to stop this from loading? They are set as nulls, but it seems to still affect my data

1 Solution

Accepted Solutions

Re: Loading empty rows

Can you explain about little bit more??

what is you source data??

is your all fields in that rows are empty?

can you post your script here?

 

as @Channa suggested use where clause to restrict load.

like 

Load * 

from tableName 

where len(trim(FieldName1))>0;

 

Regards,

Great dreamer's dreams never fulfilled, they are always transcended.

View solution in original post

5 Replies
Channa
Valued Contributor III

Re: Loading empty rows

use where column is not null

if ur loading from database

Channa
macdonaldm
New Contributor

Re: Loading empty rows

Can you please elaborate?

Channa
Valued Contributor III

Re: Loading empty rows

try in where column1 is not null 

Channa

Re: Loading empty rows

Can you explain about little bit more??

what is you source data??

is your all fields in that rows are empty?

can you post your script here?

 

as @Channa suggested use where clause to restrict load.

like 

Load * 

from tableName 

where len(trim(FieldName1))>0;

 

Regards,

Great dreamer's dreams never fulfilled, they are always transcended.

View solution in original post

macdonaldm
New Contributor

Re: Loading empty rows

Uploading from an excel spreadsheet that is uploaded to qlik cloud, and then the app pulls the data from there. SO the table I'm having trouble with looks like this:


LOAD
"Sale Key",
"Year",
"Month",
Customer,
"Service Type",
"Sale Info",
"Team Member",
"Sale Amount"
FROM [lib://qlikid_macdonald.meghann/Master Sales Data Sheet DRAFT.xlsx]
(ooxml, embedded labels, table is [Sales Closed]);

And then is loading 999 rows, even though 989 of the rows are completely empty. I tried clearing all the formatting/data validation/ etc before uploading. where does the len(trim(FieldName1))>0; go? 

 

EDIT: All set, I put that function before the ; and it solved the problem. Thank you!