Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Lost Connection HTTP QlikSense

I've created a QlikSense server install on Port 80 HTTP.

I can connect locally on the server without issue, but if I try to connect from a client machine I get the following error:

QS lost conn.PNG.png
I'm getting a response from the server (see error message) and the authentication is working as if I try a different password it asks for the authentication again.

Port 4248 and 80 are open on the server firewall.

Any ideas ?

1 Solution

Accepted Solutions
Employee
Employee

Re: Lost Connection HTTP QlikSense

Hi Brad,

It seems that with version 1.1 - they took out the Virtual Proxies section and made it a new menu item off of the main menu:

Click Virtual proxies - then make sure the Advanced section is checked, scroll down and you should see the White list setting.

Let us know how you do.

Mike T

Regards,
Mike Tarallo
Qlik
9 Replies
korsikov
Valued Contributor II

Re: Lost Connection HTTP QlikSense

yes I have some idea.

Do you give for user any access pass?

how are you allow access qlik sense server throw http?

you need https://yourserver/qmc/proxies/

edit proxy - check option Allow HTTP

tap
Contributor

Re: Lost Connection HTTP QlikSense

You need to add the server address/IP to the proxy whitelist.

From the QMC go to Proxies on the left (towards the bottom)

Highlight the "Central Proxy" and click Edit.

At the bottom of this screen is "Websocket origin whitelist"

You need to "Create new" and add the IP of the server.

You should then be able access the server from a remote machine using http://<IP>/hub fine.

Employee
Employee

Re: Lost Connection HTTP QlikSense

Hello Quinton - Alex and Tim have provide valid suggestions to this issue. Usually this will occur when the hostname / machine name / IP Address is not recognized by the proxy service. Since you are allowed to log in, you DO have assigned the appropriate access pass.

Take a look at the proxy setting and see if Tim's suggestion addresses the issue. If so, please mark the appropriate replies as helpful / correct so our team and other members know that your question(s) has been answered to your satisfaction.

Regards,

Mike T

Qlik

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Lost Connection HTTP QlikSense

Hi Tim - already tried this but it didn't solve the issue. That's why I was wondering if there's a port that I haven't opened yet? The error message points to the proxy whitelist but says :

Wbsocket origin not allowed http://myserver:84/hub . Crrent whitelist http://myserver:84/hub ??

e.g. not allowed but the address is whitelisted. Is it because of the port forward? (I'm using this as I'm in a development environment).

Employee
Employee

Re: Lost Connection HTTP QlikSense

Hi Quinton - just to make sure - are using the http and the port number (text) in the URL? or just the host name?

If you want to change the listening port - you do that in the port settings and you do not need to put the port or the http in the websocket origin white list.

Mike

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Lost Connection HTTP QlikSense

So many thanks to all that contributed - all of the comments were valid components. The issue that I was experiencing was due to the SYNTAX of how I added the URL to the whitelist.

I was trying:

http://myserverurlSmiley Tongueortnumber/hub

eg. http://my.qliksense.com:8080/hub

what is required is simply the url without the http reference or port ( as Michael correctly pointed out, this is handled in the port setup - you don't need to reference it in the whitelist)

SO the correct syntax for my server whitelist was simply:

my.qliksense.com

Thanks to all that helped - I hope this helps others.

Cheers

Quinton

bradshields
Contributor

Re: Lost Connection HTTP QlikSense

Mike I have the same problem in 1.1 and I don't see the screen you mention.

Employee
Employee

Re: Lost Connection HTTP QlikSense

Hi Brad,

It seems that with version 1.1 - they took out the Virtual Proxies section and made it a new menu item off of the main menu:

Click Virtual proxies - then make sure the Advanced section is checked, scroll down and you should see the White list setting.

Let us know how you do.

Mike T

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Lost Connection HTTP QlikSense

Mike,

I have the same problem. I did added the ip of the server i have installed Qlik Sense. But i am still facing the Issue.

surprising thing is i can access the the hub on the server but not on other nodes. but i managed to view the qmc on that other node. so my question is, am I missing some configurations. Also just to be sure do i need to allow the port 4244 and port 4248 on the network firewall?

Community Browser