Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
mapratt82
Creator
Creator

Missing Months?

I have several line charts that are missing months in the data due to either no new account opened or no transaction depending on the measure. I have added a master calendar in hopes that it might fix my problem however it hasn't and I believe the problem is going to be resolved in my set analysis. 

I have the below dimension and measure in a line chart with Aug2018 missing. I do have a master calendar with AcctOpenedDate as the key and AcctOpenedMonth as one of the fields. I would like to see Aug2018 with 0 for the value, if there is none.

Dimension: AcctOpenedMonth

Measure: Count(distinct {1<
                     ProductName = {'STAR REWARDS SAVING'},
                     CampaignDesc = {'Star Rewards Savings'},
                     AcctOpenedDate = {'>=6/01/2018'}
                   >} dimAccountID)

    also tried: alt(Count(distinct {1<
                            ProductName = {'STAR REWARDS SAVING'},
                            CampaignDesc = {'Star Rewards Savings'},
                            AcctOpenedDate = {'>=6/01/2018'}
                          >} dimAccountID),0)

Any help would be greatly appreciated!

Labels (2)
5 Replies
vikramv
Creator III
Creator III

Have you tried this , 

Go to Edit Mode : Select the Line chart --> Appearance --> X-Axis --> Change Option Continuous from Auto to Custom --> Now select "Use Continuous Scale" option

Vikky

mapratt82
Creator
Creator
Author

Thanks for the reply, unfortunately the notification went to my spam folder, so I just realized someone had replied. I did try your suggestion, but it swapped my months to a numeric value and scale. So not sure what to do?!

vikramv
Creator III
Creator III

Try un-checking the option "Use Continuous Scale" in addition to what I mentioned earlier.

 

mapratt82
Creator
Creator
Author

If I un-check "Use Continuous Scale", it does change the months back to MonthName, however I still have the missing months.

vikramv
Creator III
Creator III

This should work , If you have a master calendar .

Go to Edit Mode : Select the Line chart --> Appearance --> X-Axis --> Change Option Continuous from Auto to Custom --> Now select "Use Continuous Scale" option

 

But may be you have zero values try checking the below option as well.

Add-Ons --> Data Handling --> InClude Zero Values.