Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Make your voice heard! Participate in the 2020 Wisdom of Crowds® Survey. BEGIN SURVEY
Highlighted
mrmatt
New Contributor III

Money format pattern not producing expected result

Hello,

I have a number which defaults like this: 100260943.07 which I want to  format as a currency. I used a custom format of this: $#,##0.00 and the result was this:  $100260943,##0.00. However my expected/desired result is this:  $100,260,943.07.

What am I doing wrong and/or how do I modify the format to obtain my desired result?

thanks,

 

11 Replies
Highlighted
Luminary
Luminary

Re: Money format pattern not producing expected result

Try: '$#,##0.00;-$#,##0.00'

Blog: WhereClause   Twitter: @treysmithdev
Highlighted
mrmatt
New Contributor III

Re: Money format pattern not producing expected result

@treysmithdev thanks for trying but it also gave me $100260943,##0.00

Highlighted
Luminary
Luminary

Re: Money format pattern not producing expected result

Can you please share your expression.

Also, check your localization variables, the generated variable statements in script editor.

Blog: WhereClause   Twitter: @treysmithdev
mrmatt
New Contributor III

Re: Money format pattern not producing expected result

@treysmithdev thank you. My expression is simply Sum([Actual'18]). I'm using "Money" in the Number formatting and my Format Pattern is $#,##0.00;-$#,##0.00.

Highlighted

Re: Money format pattern not producing expected result

If you have other few values which are different than original, Share them as well. You can try?

Num(100260943.07, '$###,###,###.##')

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Highlighted
mrmatt
New Contributor III

Re: Money format pattern not producing expected result

perhaps these screenshots will help, I'm sure it's simple but I haven't been able to get it yet:

 

expression.pngresult.png

Highlighted
y_grynechko
Contributor III

Re: Money format pattern not producing expected result

Capture.PNG

Just to make sure, does the above set up fail for you to work? 

Highlighted
Partner
Partner

Re: Money format pattern not producing expected result

Hi

try to set the variable like this

SET MoneyFormat= '$#,##0.00;-$#,##0.00';

Highlighted
mrmatt
New Contributor III

Re: Money format pattern not producing expected result

@y_grynechko yes, that's exactly what I have and it's not working. Any ideas why?