Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
madmax88
Creator II
Creator II

NPrinting Connection to Server

Hi,

I have 2 Servers: On Server A QS is installed and on Server B NPrinting.

On both Servers I have a Service User (A and B) who are running the Services.

On the Nprinting Server B i have installed the 3 certificates from the QS QMC (Server A). There is no Firewall between these Servers and Service User B has Access to Server A.

Now I've tried a Connection to an app, but there is an error message as "something went wrong with the current Operation".

Proxy Adress: https://fullserver name

Sense ID: the app ID

Identity: DOMAIN\Service User B

Did I Forget something?

1 Solution

Accepted Solutions
madmax88
Creator II
Creator II
Author

Problem Solved: The Service User wasn't in my Selection Access Table (Excel File)

View solution in original post

6 Replies
rubenmarin

Hi Max, I suposse that both are local admins in their respective machines and User B has logon as a service rights.

User B also needs to be RootAdmin in qmc.

https://help.qlik.com/en-US/nprinting/September2018/Content/NPrinting/DeployingQVNprinting/User-acco...

You can check logs In ProgramData\Nprinting\Logs for additional information on errors

madmax88
Creator II
Creator II
Author

Hi Ruben,

Both are Admins on their local machine. And both Service Users has Root Admin rights on QS...

And I still get this message....any other Ideas?

rubenmarin

Hi Max, retry connection to the app and check the logs (C:\ProgramData\Nprinting\Logs) for additional information about the error.

Confirm local windows firewall is not blocking connections to the needed ports:

https://help.qlik.com/en-US/nprinting/September2018/Content/NPrinting/DeployingQVNprinting/Ports.htm

madmax88
Creator II
Creator II
Author

update: Creating Connection is working, but if I reload the Metadata, then I get the message

"Connection failed on all NPrinting enignes". How is it possible?

madmax88
Creator II
Creator II
Author

Problem Solved: The Service User wasn't in my Selection Access Table (Excel File)

View solution in original post

rubenmarin

I suppose that you have already configured an engine... have you checked any of the logs to get additional info?