Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Qlik® Product Spotlight: Discover what’s possible. Get more from our products.
See for yourself. Register today.
Not applicable

Need Help : Qlik Sense

Hi Friends,

I am trying to plot a graph where wanted to show the average headcount month on month. Data has a columns which contains closing headcount of the month.

The formula am trying is as follows:

(Count of closing headcount of current month + Count of closing headcount of previous month) / 2

Please help in getting the same. Dummy data is attached for reference.

1 Solution

Accepted Solutions
sunny_talwar
Not applicable

Re: Need Help : Qlik Sense

Oops, fixed now

11 Replies
sunny_talwar
Not applicable

Re: Need Help : Qlik Sense

Try this:

If(RowNo() > 1, RangeAvg(Above(Count([Emp Name]), 0, 2)))

Capture.PNG

Not applicable

Re: Need Help : Qlik Sense

Thanks Sunny !! Its working fine. Can you do one more favor on tis please.

have added one more column which has client names like: A & B. When am trying to get the average headcount for A & B separately, data is not showing correct. This is what m using:

If(RowNo() > 1, [Client]={"A"}, RangeAvg(Above(Count([Emp Name]), 0, 2)))

Please see if there is a way..

sunny_talwar
Not applicable

Re: Need Help : Qlik Sense

Not sure what you are trying to do, can you may be elaborate a little?

Not applicable

Re: Need Help : Qlik Sense

Earlier, we have two columns in the data which contains Employee Name and Headcount as on closing of the month. Now Have added one more column into the data which has client names like A&B. So now I am trying to get the average headcount month on month separately for Client A & B.

You may add the column named Client fill randomly A or B.

Hope this clarifies.

sunny_talwar
Not applicable

Re: Need Help : Qlik Sense

May be like this:

Aggr(If(RowNo() > 1, RangeAvg(Above(Count([Emp Name]), 0, 2))), Client, MonthEnd)


Capture.PNG

Not applicable

Re: Need Help : Qlik Sense

I presume, you attached the wrong qvf file.....

sunny_talwar
Not applicable

Re: Need Help : Qlik Sense

Oops, fixed now

Not applicable

Re: Need Help : Qlik Sense

Thanks a ton Friend :-)

sunny_talwar
Not applicable

Re: Need Help : Qlik Sense

Kaushal I am glad you found your solution, but I request you to mark only those answers as correct or helpful which actually provide a real solution my friend. "Oops, fixed now" doesn't really provide much of a solution and won't help people in the future.

Qlik Community Tip: Marking Replies as Correct or Helpful

Best,

Sunny