Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Not filtering when selected through Filter Pane

Hi all,

I have a sheet which has pivot tables with some counts.

when i tried to filter the counts through client it's filtering, same way it's filtering through batch of that client, is also filtering.

But when i tried to filter through the campaign of the same client and batch, it's not working.

what may be the reason? can any one help on this.

Sorry i don't have any sample data to post.

Thanks,

Pramod

Tags (1)
9 Replies
awhitfield
Esteemed Contributor

Re: Not filtering when selected through Filter Pane

Hi Kumar,

can you upload the qvw?

HTH

Andy

ogster1974
Honored Contributor II

Re: Not filtering when selected through Filter Pane

check your data model if there is no direct association this will not filter.  Implied associations are not supported.

Not applicable

Re: Not filtering when selected through Filter Pane

As i am working on server and i don't have any sample qvf.

LOAD `batch_meta_data_id` as batch,

    `campaign_name`;

SQL SELECT `batch_meta_data_id`,

    `campaign_name`

FROM CAMPAIGNNAMES;

LOAD `invitation_id`,

    `user_signed`,

    landing_page_accessed,

    batch_meta_data_id as batch,

    referrer_email_type_id as email_type_id,

    date(floor(date_accessed),'MM-DD-YYYY') as date_accessed,

   date(floor(date_signed),'MM-DD-YYYY') as date_signed;

SQL SELECT `invitation_id`,

  batch_meta_data_id,

     referrer_email_type_id,

    `user_signed`,

    `date_signed`,

    date_accessed,

    landing_page_accessed

FROM SIGNUPACTIVITYLOG WHERE client_id in (6,12,13,15,16,3,8,10,18,19);

`campaign_name` is the field name i am using to filter the count.


My measures are:

count({$<email_type_id = {44,45,46,47,126}>}user_signed)


These two tables are linked with "batch", but not filtering.

Re: Not filtering when selected through Filter Pane

Hi Kumar, for the behavoiur seems that the values loaded from CAMPAIGNNAMES don't exists in SIGNUPACTIVITYLOG, I would try to load those fields with different names, adding a field to each table (batchCampign and batchSignup), reload and check if there are coincidencies betwwen values.

Not applicable

Re: Not filtering when selected through Filter Pane

Can you explain with the load statement i have given, i am bit confusing

Not applicable

Re: Not filtering when selected through Filter Pane

yes, i don't have direct association with these two tables. To achieve association i am loading

batch_meta_data_id as batch in both the tables, which creating the association between these tables,

but after this also it's not working.

Re: Not filtering when selected through Filter Pane

LOAD `batch_meta_data_id` as batch,

     `batch_meta_data_id` as batchCampaign,

    `campaign_name`;

SQL SELECT `batch_meta_data_id`,

    `campaign_name`

FROM CAMPAIGNNAMES;

LOAD `invitation_id`,

    `user_signed`,

    landing_page_accessed,

    batch_meta_data_id as batch,

     batch_meta_data_id as batchSignup,

    ......

FROM SIGNUPACTIVITYLOG WHERE client_id in (6,12,13,15,16,3,8,10,18,19);

Your script seems ok, this is to check the data, when you select a campaign_name it should filter the records of SIGNUPACTIVITYLOG with the same batch, if it's not working maybe is because there are different values, this way you can confirm or discard this hypothesis.

ogster1974
Honored Contributor II

Re: Not filtering when selected through Filter Pane

He's saying your load looks ok as you have a join on batch.

What you need to investigate is your data when you filter on a campaign it results in 1 or more batch ids.  are these present in your fact table SIGNUPACTIVITYLOG.  If yes do the log records appear for email_type_id = {44,45,46,47,126}

ogster1974
Honored Contributor II

Re: Not filtering when selected through Filter Pane

take a campaign you expect a result on and trace it through your app to identify the disconnect.  As you have a join it is probably a data issue.

Community Browser