Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

ODBC over WAN on Qlik Sense

Hi,

I am trying to get the ODBC to connect over WAN to my data server. I have successfully connected on local machine but an unsure where to start to edit the connection in Qlik Sense to do this.

Any advice welcome, thank you.

7 Replies
walterlh
Contributor II

Re: ODBC over WAN on Qlik Sense

dale un vistazo a esto!hiii

Not applicable

Re: ODBC over WAN on Qlik Sense

Thank you but that is for Qlik View not Qlik Sense. Those options are not available in Sense unfortunately.

Employee
Employee

Re: ODBC over WAN on Qlik Sense

Hi , two steps:

1. First create the ODBC connection from your ODBC Administrator first :

on windows 7 for example:   Start -> Control Panel -> System and Security -> Administrative Tools -> Data Sources (ODBC)

I suggest creating a new 'System DSN' using an available ODBC driver .  ***you need to ensure you have an ODBC driver available . Qlik Sense does not provide one***

2. In Qlik Sense:

a) open your app or create a new app

b) In the top left corner drop down , select 'Data Load Editor'  (This will open the load editor)

c) On the right side , click 'create a new connection' and then select 'ODBC'

d)  You should see your DSN from step 1 above. If you don't try toggling the 32 vs 64 bit button to see if it comes up

e) enter a suitable userID and password and hit ok -> this create a connection show on the right side

f)  on the right side, you'll notice an icon underneath your connection that on hover over says 'select data' . hit that and you can select what you want to bring into your qlik sense app.

Employee
Employee

Re: ODBC over WAN on Qlik Sense

Hi Aaron - in addition to my colleague Jonathan's answer - have you checked out these videos here:

New to Qlik Sense Videos

One of them shows how this is done:

Data Load Editor - Loading ODBC Data (video)

Please let us know how else we can help you.

Regards,

Mike

Not applicable

Re: ODBC over WAN on Qlik Sense

Hi, Thanks for those and yes I have seen them. That was what got me to the step of how to connect over the WAN rather than Localhost.

Now I have to go and work out how to configure the options outlined by Jonathon. I just did not realise that there was a step outside of the Qlik process. Got to love a steep learning curve.

Thanks again.

Employee
Employee

Re: ODBC over WAN on Qlik Sense

Hi Aaron -

Great to hear, technically it is very common with almost any BI product to setup a System or User DSN to connect to a specific ODBC source especially if the specific data driver is not listed. We categorize our connections to data and list them as ODBC and OLEDB, File etc.  - and then provide the installed driver list depending on the configuration on your system vs. creating a list of every named data source out there.   I am not sure what your source is, but if there was a drive available for OLE DB - you would not need to setup the DSN for ODBC. For example, Oracle, MS SQL etc have OLE DB drivers you could use and just configure the host name, port, database and credentials - much straightforward.

Let us know how else we can help, we want to make your experience with the product productive.

Regards,

Mike

Employee
Employee

Re: ODBC over WAN on Qlik Sense

Ah... One more thing - I just watched the video and heard - "If you don't have any ODBC connections, contact your systems administrator to help you set that up"  - OK that was not what I was expecting to hear.  I will correct this and re-record to add those steps in a future video for the Sense platform. I assumed those steps were in there. Thanks to Jonathan Poole for including them above. Note that configuring these steps in the ODBC system admin are different per data source, so if you still need help on that, let us know what data source it is and we will attempt to help.

note - it also depends on what type of driver you have installed as well - so you may need the 32-bit or the 64-bit driver depending on your data source.

Mike T