Skip to main content
Sept. 27, 10AM ET Do more with Qlik, Insight Advisor – our intelligent AI-assistant in Qlik Sense: Register
Showing results for 
Search instead for 
Did you mean: 

OLEDB Connection issue

while connecting the DB, below error getting. Kindly advise


OleDb error

Connector connect error: IDataInitialize::GetDataSource. HRESULT = 80040E4E. ErrorSource: OraOLEDB, ErrorMsg: The system cannot find message text for message number 0x80040e4e in the message file for OraOLEDB.


Labels (1)
3 Replies

somebody please help.....


The error message "OleDb error, Connector connect error: IDataInitialize::GetDataSource. HRESULT = 80040E4E" is related to an issue with the OLE DB provider when trying to connect to an Oracle database using Qlik Sense.

Here are a few things you can check to troubleshoot this issue:

  1. Verify that the OraOLEDB provider is properly installed on your machine. This provider is required to connect to an Oracle database using Qlik Sense.

  2. Verify that you are using the correct connection string. The connection string should include the server name, port number, and the service name or SID of the Oracle database.

  3. Verify that your machine can connect to the Oracle server. You can check this by trying to connect to the server using SQL*Plus or other Oracle client tools.

  4. Verify that the Oracle service is running and that the database is available and accessible.

  5. Check that the necessary Oracle client libraries are installed on your machine.

  6. Check the Oracle client version, it should be compatible with the Oracle server version you are trying to connect to.

  7. Check the windows event viewer to see if there's any errors or warnings related to the connection.

  8. You can check the Qlik Sense logs to see if there's any information that can help you to identify the problem.

If you continue to experience issues connecting to the Oracle database, you may want to reach out to your IT department or Oracle database administrator for further assistance.

Giuseppe Novello
Principal Technical Support Engineer @ Qlik


only for one DB im facing this issue, i have 4 other and that all working fine. even from control panel DNS i tried to connect the DB and its working fine. thru sql plus i tried to connect and that also working for the same account. Please advise