Skip to main content

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
Showing results for 
Search instead for 
Did you mean: 
Partner - Creator II
Partner - Creator II

On demand app generation keeps failing on data load of template app

Hi everyone,

I am trying to use the ODAG functionality in Qlik Sense. Problem is,  it keeps failing when the on demand app gets generated and it just keeps failing when it tries loading data.

To fix this I have tried the following tutorials:

Unfortunately none of these work and I have tried everything I could think of. In the end I tried generating an almost empty app with just an inline table and even that didn't work... The bizarre thing is, if I go to the generated app that gives an error and manually reload it, it does work. 

Does anyone have any idea what I am doing wrong? Or have any ideas I can try? Or maybe have some example code that does work for you?

Extra information:

  • Server version: Qlik Sense April 2019 Patch 1
  • Security access: complete access / god mode in this test environment

Thanks in advance

Labels (1)
  • ODAG

10 Replies
Partner - Creator II
Partner - Creator II

Hi guys,

Sorry for the delay, was out of the picture awhile due to the global pandemic. In the end the answer was relatively boring. It was an architectural problem that prevented different parts to communicate. We have a setup that consists of multiple environments that both have frontends/backends. This setup in combination with multiple firewalls/security rules resulted in a part of the ODAG process not being able to communicate with the required files and thus failing and not producing anything. It took multiple people multiple hours to finally find the bottleneck though, but in the end my lovely IT department redesigned the setup so it finally could communicate.

Funnily enough, I had to work with ODAG again and stumbled on a new problem, so even though this one is fixed, the next one presented itself. See here:

At least it keeps me busy............

Hope it all worked out for you guys, if I can help in any way let me know.