Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

nick_scott
New Contributor III

Organizing the script - Problem "rearranging script sections"

It should be possible to rearrange the script "Sections":

You can rearrange the order of sections to change the script execution order.

Do the following:

1.Select the section you want to move.

2.Put the cursor on the "" drag bars and drag the section to rearrange the order.

The sections have now been rearranged.

However, I can't get the Sections to move.

Only solution appears to be to create a new Section and cut & paste.

Tags (1)
1 Solution

Accepted Solutions
Employee
Employee

Re: Organizing the script - Problem "rearranging script sections"

OK great Nick - that is the issue then - I have forwarded this to Product Management for investigation.

it seems the embedded browser we use "Chormium" for the Desktop product is running into some issues with right click and draggable content with touch device PCs.

I'll post an update once i know more.

Mike T

11 Replies
pwd
New Contributor III

Re: Organizing the script - Problem "rearranging script sections"

Are you dragging them by the "drag bars"? They are just to the left of the label. It seems to work fine for me when I try it.

Employee
Employee

Re: Organizing the script - Problem "rearranging script sections"

Hi Nick,

Just to make sure there is no miss understandings.  Here is an image with instructions.  It works for me.  If it isn't working for you can you please share details of your environment.

Thanks,

Josh

2014-07-28 06_51_47-Qlik Sense Desktop.png

Employee
Employee

Re: Organizing the script - Problem "rearranging script sections"

Hi Nick - This may be similar to a recent problem I have seen with touchsmart or touch related PC devices. Is you machine a touchsmart machine - or  touch device? When you are developing, can you get a right click-menu to display?

Try opening a browser to http://localhost:4848/hub and access the scripting interface and see if you can rearrange the sections.

Let us know.

Mike T

nick_scott
New Contributor III

Re: Organizing the script - Problem "rearranging script sections"

Yes, I'm using a SONY VIAO with a 1920x1080 touchscreen display.

I can't get a "right click" on the Section.

I have opened the hub http://localhost:4848:hub in two browsers:

  1. In Chrome version 36.0.1985.125 m I can't move the Sections;
  2. In IE version 11.0.10 I can move the Sections.

I guess I can just use the IE browser

Thanks

Nick

nick_scott
New Contributor III

Re: Organizing the script - Problem "rearranging script sections"

Yes.  The "drag bar" is the obvious place to start, especially when it says "drag bars" in the Help.  But it didn't work for me, so I wondered if it was a problem.

Josh, I'll send you the Document Support Information from my Qlikview 11.2 installation.

nick_scott
New Contributor III

Re: Organizing the script - Problem "rearranging script sections"

Josh

Attached is my DSI file

Nick

Employee
Employee

Re: Organizing the script - Problem "rearranging script sections"

OK great Nick - that is the issue then - I have forwarded this to Product Management for investigation.

it seems the embedded browser we use "Chormium" for the Desktop product is running into some issues with right click and draggable content with touch device PCs.

I'll post an update once i know more.

Mike T

Employee
Employee

Re: Organizing the script - Problem "rearranging script sections"

Thanks, Nick.  Since you are able to rearrange the script from IE , then I feel we can assume the issue is due to your touch screen.  This is a known issue our engineering team is working on.

One question,  do the drag bars work for you when you use the touch interface (i.e. drag them with your finger on the display)?

-Josh

nick_scott
New Contributor III

Re: Organizing the script - Problem "rearranging script sections"

Hi Josh

No. They don’t work when I use the touch screen.

When I touch on the “drag bar” I get an initial grey “touch” circle, and then if I hold I get an orange “touch” circle flashes, but disappears. In neither state can I move the Section.

It may be related to the touch screen. I haven’t tried on a different PC. However, it doesn’t work in Chrome, but it works in IE. That seems strange.

I have a work around,

Thanks,

Nick