Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Announcements
Customers, Partners & Luminaries only: You're invited to a Data Analytics Roadmap session. Read More
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor

Powershell Qlik-CLI and Qlik Analytics Platform

Just wondering if anyone has any issues with regard to the QLIK-CLI PowerShell cmdlts  and the Qlik  Analytics Platform or QAP.  I am currently going through a process of Automating our Qlik Sense App reloads using PowerShell and CA-AutoSys.  Everything is working with the Qlik Sense side of things. But when I try to run the same style of script on the QAP Server I can successfully make a connection using the Connect-Qilk cmdlets but I cannot get any of the cmdlts to deliver a response for some reason. The issue is only isolated to the QAP Server and not the Qlik Sense Server. The Qli-CLI has been installed as per "https://support.qlik.com/articles/000047186". I'm wondering if anyone had any experience similar to this.

Labels (3)
2 Replies
Highlighted
Support
Support

Hi @michasiuk 

The Qlik-Cli tools are not supported by Qlik, we try to provide some documentation in order to provide some guidance but as the tool is not provided by Qlik configurations might change and new issues can be found.

The recommendation here is to verify if the issue you are facing was already reported at:

https://github.com/ahaydon/Qlik-Cli/issues

To configure the tool the most updated documentation is also available in the following URL, you will need to select the "installation documentation" link.

https://github.com/ahaydon/Qlik-Cli/wiki

 

Kind Regards.

 

 

Note: if this suggestion helps to resolve the issue or answers your question, it will be appreciated if you select the "Accept as Solution" option.
We encourage you to visit our Knowledge Base https://qliksupport.force.com/QS_CoveoSearch when trying to find a solution related and not limited to: errors, feature requests, product defects. You can also visit our Qlik Help portal https://help.qlik.com/
Highlighted
Contributor
Contributor

We where running the script under the service account that runs the QAP services we solved the problem by defining the service account within QAP as a root admin solved all the problems