Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Tell us which business and trade publications you read most regularly: RESPOND NOW
Showing results for 
Search instead for 
Did you mean: 
Partner - Contributor III
Partner - Contributor III

Problem with Connect-Qlik (clik-cli)


I have a powershellscript to restart a task, this is triggered through Azure so we have to use -username instead of using defaultcredentials. 

$logpath = "E:\Tools\Scripts\log.txt"
Import-Module -Name Qlik-Cli
Connect-Qlik -Computername server1 -TrustAllCerts -Username test@test.com
Start-QlikTask -id df9dfa2f-32ca-4db4-bdce-15ad924fd59f -verbose 4>&1 | Out-File -Append $logpath

But when we run it we get a cert-problem

If we run it without the thumbprint it asks for the cert and if we run with thumbprint we get the error below.

What information do you need to provide? The cert don't have a friendly name

Connect-Qlik : Cannot process argument transformation on parameter 'Certificate'. Cannot convert value "3fcad2353817a88b785b11fd743d8c3507fc8bf6" to type "System.Security.Cryptography.X509Certificates.X509Certificate". Error:
"The system cannot find the file specified.
At E:\Tools\Scripts\Tasktrigger.ps1:3 char:125
+ ... TrustAllCerts -Certificate "3fcad2353817a88b785b11fd743d8c3507fc8bf6"
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidData: (:) [Connect-Qlik], ParameterBindingArgumentTransformationException
+ FullyQualifiedErrorId : ParameterArgumentTransformationError,Connect-Qlik






Labels (2)
3 Replies
Partner - Contributor
Partner - Contributor


Did you solve this? I'm currently facing the same issue. I have exported the certificate and installed Root.cer in Trusted Root certificate store and Client.pfx in my personal store. The certificate is trusted and when trying to use Connect-qlik I also get the same issue when entering the Thumbprint for the client certificate. I've also tried the serial of the certificate but no luck there.

Would be nice to hear if you solved it!


Partner - Contributor III
Partner - Contributor III

I did yes, are you having the exact same problem with the runbook?


If so:


1. When you install QlikSense a certificate called QlikClient will be installed.
The certificate you can only find under the user you installed it, in personal store.
2. Export the certificate and then install it under the computer store in both personal and computer store.
3. When you would run the runbook the user used would be domain\Servername$
4. Run it once and that user will be imported into QlikSense, assign permission to the account and that should be it.

If this still wont work, add logging (verbose to file) and post it here and I can help you sort the last out.
It was when I looked into the code to the module I realized what the problem was.

Contributor II
Contributor II

I am having a similar issue. 
I tried exporting the certificates from QlikSense QMC and importing them to the server / workstation that I am trying to run Qlik-CLI from.
This is for some automation work I'd like to do but cannot seem to get Qlik-CLI to connect with the certificates installed and trusted.
Also, how do I invoke Verbose Logging when opening Qlik-CLI?
Thanks for any help.