Qlik Community

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Shahzad_Ahsan
Creator III
Creator III

Problem with License Allocation

Hi

I am facing an issue with license allocation. When I try to allocate license to an new user, it fails. Don't know why.

When I restart services it again starts working fine. 

What is the issue? I don't want to restart services again and again.

It is happening for both Analyzer and Professional.

Any Idea?  

Labels (2)
6 Replies
Anil_Babu_Samineni

Make sure you have proper license rules? If not, Create one and use blurred UDC define names into the condition.

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Shahzad_Ahsan
Creator III
Creator III
Author

Yes, we have proper license rule.

Let me explain my scenario.

I have 300 user license. 30 professional and 270 Analyzer. We have allocated 29 in professional and 269 in analyzer.  

I cannot allocate the last user in both (professional and analyzer). What is the issue? 

I have to deallocate the old user and give license to new user. but last user is never allocated. This is strange.

Anil_Babu_Samineni

If that is resolved, Please accept this as answer. If not, Please check once whether it has any allocation already in other ways under professional license.

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
caltmag22
Contributor III
Contributor III

Hi! Did you manage to find a solution to this problem? I am experiencing the same issue as well.

Harry_M
Partner
Partner

We have this issue as well, did any of you guys resolve it? Sounds like a Qlik software developer needs to change 'If NoofRemainingLicenses <= 1 then do not allocate'  to   'If NoofRemainingLicenses < 1, then do not allocate' 😂😂😂 .

Or is this a quarantine period issue? There's suppose to be a 7 day quarantine period even though the QMC does not show the quarantined license stats anymore. We are definitely over the 7 day period mark and yet cannot allocate the last license.

Harry_M
Partner
Partner

Update: This was resolved by simply restarting the Qlik Services on the server 😄.  Will update this post if it happens again!