Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

evgeniystuchalk
Contributor II

Problem with key field in sales and customers tables

Hello! I have two data tables: Leads and Contacts. This tables connected by key field "Contact ID". I want use some dimensions, like "Tag", from Contacts table, to slice data from Leads table. But, I don't know why, when i'm using filter in field "Tag", report behave like there is no Lead, that match filtering condition. But this Leads exist, I know it . Why field "Contact ID" don't work like a key? What am i missing?

All detail in my video (sorry my poor English )

1 Solution

Accepted Solutions
evgeniystuchalk
Contributor II

Re: Problem with key field in sales and customers tables

Solution founded! If you want use fields from additional table like dimensions for main table, YOU MUST CONNECT THEM ONLY WITH ONE KEY FIELD

This is correct conetion. Example of incorrect connection you can see in my video.

N6TMADGDQEiaKFZgEZCp3A.png

4 Replies
evgeniystuchalk
Contributor II

Re: Problem with key field in sales and customers tables

Solution founded! If you want use fields from additional table like dimensions for main table, YOU MUST CONNECT THEM ONLY WITH ONE KEY FIELD

This is correct conetion. Example of incorrect connection you can see in my video.

N6TMADGDQEiaKFZgEZCp3A.png

Re: Problem with key field in sales and customers tables

You have got synthetic keys:

not one field but multiple fields connects your tables cousing your issues

The $S.. indicates the

Look here how to get your data right

Synthetic Keys

evgeniystuchalk
Contributor II

Re: Problem with key field in sales and customers tables

Thanks! I'm already solved this and posted solution, bou it still on moderation

Re: Problem with key field in sales and customers tables

Great good for you.