Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

johnkoegel
New Contributor

Proper RIM Node Setup for Engine Service

Hi All,

I am having an issue setting up my RIM node properly, as I feel the documentation is a little ambiguous. Can someone point me to explicit documentation on this?

  1. Do I add both Central and the RIM node to the Load Balancing section of each virtual proxy?
    1. When I did so, I was seeing engine service errors.

I am happy to explain further if someone cannot point me to better documentation than this

http://help.qlik.com/en-US/sense/2.2/Subsystems/ManagementConsole/Content/add-load-balance.htm?q=loa...

Regards,

John

Tags (1)
3 Replies
johnkoegel
New Contributor

Re: Proper RIM Node Setup for Engine Service

As an additional comment - my RIM node does not have a Proxy service installed on it, it is simply the repository service and engine service. I believe if I set up "Load Balancing"  under my Central Proxy and Central Virtual Proxy, then the Central Proxy Service running on my Central Node will handle authentication and then automatically load balance following that authentication among the RIM Nodes and Central Node.

I am not seeing resources being utilized on anything other than the Central Node, however. I was led to believe it was a random load balancing, so I should be seeing utilization on the RIM Nodes. Is this true?

Employee
Employee

Re: Proper RIM Node Setup for Engine Service

This choice is your's. There are pros/cons to each choice and the right answer depends on your architecture.

At a high level, if you specify multiple Engines for load balancing for a given virtual proxy then you will share the load between those two Engine nodes.

Many customers prefer the architecture of having the Central isolated from most, if not all, activities. So for these customers they would have an architecture like this:

Central: Central Virtual Proxy load balancing off the Central

Engine Node

Proxy Node: Proxy Node's virtual proxy load balancing off the Engine node

rossdoug
New Contributor II

Re: Proper RIM Node Setup for Engine Service

I'm having this exact problem as well.  The rim node is there with all services running, but it is sitting idle while several users are hammering the central node.

Did you ever find a solution for this?

Community Browser