Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

abhaysingh
Valued Contributor II

QLIKSENSE SECTION ACCESS NOT WORKING

Hi all,

i tried to implement section access on server as mentioned below.. but it is not working... right now i m login through user Sense and when i m running that script country Germany and UK  only coming.. can any one pls tell me what is the Mistake m doing???

Section Access;

LOAD * Inline

[ADMIN, USERID, PASSWORD, COUNTRY

  ADMIN, Domain\sense, Sense@123, *

    USER, Domain\Test1, Test1,GERMANY

    USER, Domain\Test1, Test1,UK

];

Section Application;

thanks

Abhay

1 Solution

Accepted Solutions

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Abhay,

Change the value "ADMIN" to "USER". This will be fixed in coming versions

Remove the PASSWORD field from Section Access

Use all field values and names UPPERCASE

More help here: http://help.qlik.com/sense/en-US/online/#../Subsystems/Hub/Content/Scripting/Security/DynamicDataRed...

Miguel

16 Replies
abhaysingh
Valued Contributor II

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Kindly revert

Not applicable

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Did you find and solve the issue?

abhaysingh
Valued Contributor II

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Sry not yet Hampus..

mhk
New Contributor III

Re: QLIKSENSE SECTION ACCESS NOT WORKING

For future reference, please avoid all capital subject-lines.

Qlik Sense does not use the PASSWORD field in section access, I would start with removing it.

Then, the line "[ADMIN, USERID, PASSWORD, COUNTRY" is incorrect, as the first column-name  should be "ACCESS" instead of "ADMIN".

Please let us know if the changes fixed the problem.

Partner
Partner

Re: QLIKSENSE SECTION ACCESS NOT WORKING

In Qlik Sense it seems that ADMIN does not work.

by the way, the first column should be ACCESS

For reload jobs, you also need to add user INTERNAL/SA_SCHEDULER which is starting reload tasks in mgc

Regards

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Abhay,

Change the value "ADMIN" to "USER". This will be fixed in coming versions

Remove the PASSWORD field from Section Access

Use all field values and names UPPERCASE

More help here: http://help.qlik.com/sense/en-US/online/#../Subsystems/Hub/Content/Scripting/Security/DynamicDataRed...

Miguel

abhaysingh
Valued Contributor II

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Hi,

Section Access;

LOAD * Inline

[ACCESS, USERID,  COUNTRY

  ADMIN, Domain\SENSE,

    USER, Domain\Test1,GERMANY

    USER, Domain\Test1, UK

];

Section Application

AFTER DOING SO GIVING ME ERROR WHILE OPENING APPLICATION.....

AN ERROR OCCURRED..  ACCESS IS DENIED

Kindly Suggest

THANKS

abhaysingh
Valued Contributor II

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Hi,

what is that issue i tried in one more application and again i m getting same ACCESS DENIED ISSUE..

kinldy suggest...

thanks

Abhay

abhaysingh
Valued Contributor II

Re: QLIKSENSE SECTION ACCESS NOT WORKING

Hi Miguel..

Is there any QMC Setting need to apply because i tried the same you suggest and added INTERNAL/SA_SCHEDULER suggested by martin.. and as per Access Denied Error giving which seems some other setting need to apply for this.

thanks

abhay