Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Qlik Sense 3.1 SR3 Binary Load Stopped working

I have a Qlik Sense Application that I am using a Binary Load on that has been working in previous versions of Sense.  We recently upgraded to 3.1 SR3 and the Binary Load is now failing without much of an error message.

The error is:  Data has not been loaded. Please correct the error and try loading again.

My binary statement at the very beginning of the load is:

Binary lib://MyConnection/BinaryLoadingApp.qvw;

Anyone else seeing this issue in 3.0?  And is there anyway I can see an actual error message or are there any fixes?  I haven't been able to find anything.

9 Replies
Not applicable

Re: Qlik Sense 3.0 Binary Load Stopped working

We recently upgraded to sense 3.1 SR3. 

Partner
Partner

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

Hi Jon,

I've experienced the same message, but loading directly from a QS's app.

A couple of questions:

  1. if you try to debug, the error changes (in my case, it did)
  2. the .qvw from which version of QlikView has been created? Possibly (I haven't tried, so don't take it as "absolute truth") if it was an older version, the structure of the data below could have changed and not be compatible 100%
  3. since upgrade, have you restarted the machine? (i usually do when upgrade one of our systems)
MVP & Luminary
MVP & Luminary

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

The specific error message can be found in the reload log at:

QS Desktop: C:\Users\userid\Documents\Qlik\Sense\Log

QS Server:

C:\ProgramData\Qlik\Sense\Log\Script

or

C:\ProgramData\Qlik\Sense\Repository\Archived Logs\your_server_name\Script

Not applicable

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

I've tried switching it to Binary Load off of different qvw's with the same results.  The QVW's were created with QlikView 11. 

This is on QlikView server.  I can try and see if this occurs on QlikView desktop as well.

Not applicable

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

Thanks Rob,

Found the log and it gave me a "General Script Error"

2016-12-22 08:01:24      General Script Error

2016-12-22 08:01:24      Execution Failed

2016-12-22 08:01:24      Execution finished.

Partner
Partner

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

The qvw has section access? if the users that runs the QS server isn't in it, it can't binary load the app.

Also, would it be possible for you to install QV > v12 and save again the application (with another name... just in case)? A desktop version should be good for the test

Then try to binary load this new qvw from QS

MVP & Luminary
MVP & Luminary

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

"General Script Error" in the dreaded uncaught error. I would contact QT support.

-Rob

Not applicable

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

It looks like Ricardo was on the right path.  We haven't fixed it yet but it looks like the problem is the qvw has Section Access. 

Is there a special way to Binary Load off of a qvw that has Section Access and you are trying to load from Sense?  The user that tried to do this and myself should have both had access to this qvw via Section Access. 

This is going from Qlik Sense Server to a qvw.


Thanks

Partner
Partner

Re: Qlik Sense 3.1 SR3 Binary Load Stopped working

From what I know it's not possible to remove/don't observe the Section Access when you do a binary load...

As a workaround you could do (in a new qvw) a binary load to the original document using your user (in order to load the data) and add at the section access the user that is used by the QS services. Obviously removing at all the section access (maybe only on a copy of the application that is not used by the end-users) is indeed another way to do this.