Qlik Community

New to Qlik Sense

Discussion board where members can get started with Qlik Sense.

Not applicable

Qlik Sense - Active Directory - User Directory Connection

Hi

I have set up a User Directory Connection using the Active Directory option.  When I click Apply it states the connection update was successful and no errors are generated.

I have entered the Path - LDAP://dc1.transversalcorp.local but no username and password.has been entered as it errors.

I then go a SYNC the new connection, which takes seconds!!  However no users are imported in. 

The following is recorded in the log file. (see attached - logfile.txt)

Can anyone help explain why the users are not imported.

Thanks


Sarah Owen

1 Solution

Accepted Solutions
Not applicable

Re: Qlik Sense - Active Directory - User Directory Connection

Thanks Michael

The issue related to the Connection Path,  I was using

LDAP://dc1.trxxxxxxxxx.local/

instead of

LDAP://dc1.trxxxxxxxxx.local/OU=SBSUsers,OU=Users,OU=MyBusiness,DC=Traxxxxxxx,DC=local

Once the correct path was specified no username / password was required,

6 Replies
Gethyn
Contributor

Re: Qlik Sense - Active Directory - User Directory Connection

Take a look at this, you might have to add your username and password.

http://www.qliktips.com/2011/06/nobody-said-it-was-easy-configuring.html

Not applicable

Re: Qlik Sense - Active Directory - User Directory Connection

If the Qlik Sense service does not have access to read the active directory you are adding then it will error.  As Gethyn stated, you likely need to add an account and password for an account on that domain that can read the active directory.

darkhorse
Valued Contributor

Re: Qlik Sense - Active Directory - User Directory Connection

Hello,

If you are trying to get the local users, then you cannot sync them as far as I remember (may be subject to change in new version not sure).

You need to make them log in to Hub and then they will appear in QMC. Try like that.

BR

Serhan

Employee
Employee

Re: Qlik Sense - Active Directory - User Directory Connection

Hi Sara - I had the same issue the other day with my AD, as Jeff has stated - the user account running the Qlik Services should have the appropriate read access to the domain controller where the AD lives in order to pull in the user information to the Qlik Sense repository.

However, once I added my domain\id and password in the input box - and then sync'd - I clicked refresh and saw the status chang to fetching users.

Let us know if you have any other questions.

Please mark the appropriate replies as CORRECT / HELPFUL so our team and other members know that your question(s) has been answered to your satisfaction.

Regards,

Mike Tarallo

Qlik

Regards,
Mike Tarallo
Qlik
Not applicable

Re: Qlik Sense - Active Directory - User Directory Connection

Thanks Michael

The issue related to the Connection Path,  I was using

LDAP://dc1.trxxxxxxxxx.local/

instead of

LDAP://dc1.trxxxxxxxxx.local/OU=SBSUsers,OU=Users,OU=MyBusiness,DC=Traxxxxxxx,DC=local

Once the correct path was specified no username / password was required,

Employee
Employee

Re: Qlik Sense - Active Directory - User Directory Connection

Cool - thanks for the update.

Regards,
Mike Tarallo
Qlik
Community Browser