Qlik Community

Ask a Question

New to Qlik Sense

If you’re new to Qlik Sense, start with this Discussion Board and get up-to-speed quickly.

Qlik Users, make your voice heard! Participate in Wisdom of Crowds® Market Study: Start Survey
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Qlik Sense Bucketed Column - Invalid Params?!

Hello dear people,

I have a problem with creating a bucketed column in my table in Qlik Sense. After the bucketing didn't work in the dimension editor, I went into the data manager, loaded the tables and configured 11 buckets containing values between roughly -100 and +8,000,000,000. Configuration worked great, only when I want to "publish" the column, a window pops up titled "Devhub.ErrorDialog.Title" saying "Invalid Params" and I can't find the column anywhere in the sheet editor. I've tried googling the problem, but even Google just returns 5 search results that don't get me anywhere. With all my other charts, the bucket configuration via dimension editor worked perfectly (and I used the exact same syntax), so I don't know what could be the problem there.

Any help would be greatly appreciated.

Thank you in advance,


4 Replies

I'm guessing that there is something in there left over from when you tried to build it the first time. 

Is there any extra code in your script that you might have missed that needs to be removed?

Worst case create a new app starting with just your script and see if you have the same issue.  If not, then just delete the old one and use the new one.

Contributor III
Contributor III


thank you for your answer.

So my "old" script - the one that works - looks like this:

=  IF([column A] < -45, '< -45 %',

IF([column A] < -30,'-45 to -30 %',

IF([column A] < -15,'-30 to -15 %',

IF([column A] < 0,'-15 to 0 %',

IF([column A] < 15,'0 to 15 %',

IF([column A] < 30,'15 to 30 %',

IF([column A] < 45,'30 to 45 %',

IF([column A] < 60,'45 to 60 %',

IF([column A] < 100,'60 to 100 %', 

IF([column A] < 500,'100 to 500 %',

IF([column A] < 1000,'> 500 %'))))))))))

And the new script looks like this:

=  IF([column C] < -150, '< -150 %',

IF([column C] < 0,'-150 to 0 %',

IF([column C] < 150,'0 to 150 %',

IF([column C] < 300,'150 to 300 %',

IF([column C] < 500,'300 to 500 %',

IF([column C] < 1000,'500 to 1000 %',

IF([column C] < 10000,'1000 to 10000 %',

IF([column C] < 1000000,'10000 to 1000000 %',

IF([column C] < 10000000,'> 1000000 %')))))))))

Am I missing something? To me they look the same


They are clearly not the same.  The 2nd script is a different field and the values and ranges are different. 

That being said did you try to copy the 2nd one into a new app and just try to see if it works?  If it does, then there is something corrupt in your original app.  If it still doesn't work then there is something wrong with what you are trying to do.

In the example that works you have 11 Ifs and 10 ) at the end.  In the 2nd example you have 9 Ifs and 9 ) at the end.

I wonder if that might be a problem.

Contributor III
Contributor III

Hey Mark,

well, of course the values are different, but the function is the same. I finally fixed it using the Dual function in a dimension. Thank you for your help though!